summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-10-17 11:25:52 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-10-17 14:02:15 +0100
commit41be80a8cae1eb0e294392e5033511bfdf2895c5 (patch)
treec55fbda07248a91a337f98828e5e09715f747582 /configure.ac
parentba6c82cd9d8089354b90632ca8edbb35cc09b9c4 (diff)
downloadxf86-video-intel-41be80a8cae1eb0e294392e5033511bfdf2895c5.tar.gz
xf86-video-intel-41be80a8cae1eb0e294392e5033511bfdf2895c5.tar.bz2
xf86-video-intel-41be80a8cae1eb0e294392e5033511bfdf2895c5.zip
sna: Enable support for SECURE batch buffers
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 972d9188e..ab3f3d2ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -292,6 +292,15 @@ if test "x$USERPTR" = xyes; then
AC_DEFINE(USE_USERPTR,1,[Assume USERPTR support])
fi
+AC_ARG_ENABLE(secure-batches,
+ AS_HELP_STRING([--enable-secure-batches],
+ [Enable use of secure batches (experimental) [default=no]]),
+ [SECURE_BATCHES="$enableval"],
+ [SECURE_BATCHES=no])
+if test "x$SECURE_BATCHES" = xyes; then
+ AC_DEFINE(USE_SECURE_BATCHES,1,[Test for kernel support of secure batches])
+fi
+
AC_ARG_ENABLE(async-swap,
AS_HELP_STRING([--enable-async-swap],
[Enable use of asynchronous swaps (experimental) [default=no]]),