summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 15:51:06 -0500
committerSung-Jin Park <sj76.park@samsung.com>2013-09-02 23:32:30 -0400
commit963f149e21b40cfed9fa440e94c66f70177f0eb3 (patch)
treed5065da401ecb756de2a7091a7eb6b13da91533b /Makefile.am
parent0a18989e8819023c32a2ad896fc12c6a2a2872ac (diff)
downloadxev-963f149e21b40cfed9fa440e94c66f70177f0eb3.tar.gz
xev-963f149e21b40cfed9fa440e94c66f70177f0eb3.tar.bz2
xev-963f149e21b40cfed9fa440e94c66f70177f0eb3.zip
Add missing PHONY line for automatic ChangeLog generation
Change-Id: I3a6f11140672b863edddd66dafb0e0afde8bc61e
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 61a3e84..3af1bda 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,6 +63,8 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+.PHONY: ChangeLog
+
ChangeLog:
(GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
dist-hook: ChangeLog