summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChangyeon Lee <cyeon.lee@samsung.com>2014-04-17 14:39:53 +0900
committerChangyeon Lee <cyeon.lee@samsung.com>2014-04-17 14:46:23 +0900
commit062ccfe1d8b185769f7fba8592a847534ddcd20f (patch)
tree3c835328760e4ff97c51f8299f9e8e1f023a7d41 /Makefile.am
parent58f5b6fa650fec45dc1550c9c8f53d5be6e04891 (diff)
parentbf7133e53f270b44a263e4f364642c2cae384496 (diff)
downloadxconsole-062ccfe1d8b185769f7fba8592a847534ddcd20f.tar.gz
xconsole-062ccfe1d8b185769f7fba8592a847534ddcd20f.tar.bz2
xconsole-062ccfe1d8b185769f7fba8592a847534ddcd20f.zip
Change-Id: Ied4732bb27f4d8a89f7ba0e596231a81bf70ab93 Signed-off-by: Changyeon Lee <cyeon.lee@samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 4 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 5e9d16f..2619c76 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
-#
+#
# Copyright 2005 Red Hat, Inc.
-#
+#
# Permission to use, copy, modify, distribute, and sell this software and its
# documentation for any purpose is hereby granted without fee, provided that
# the above copyright notice appear in all copies and that both that
@@ -10,7 +10,7 @@
# specific, written prior permission. Red Hat makes no
# representations about the suitability of this software for any purpose. It
# is provided "as is" without express or implied warranty.
-#
+#
# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
@@ -19,6 +19,7 @@
# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
# PERFORMANCE OF THIS SOFTWARE.
+SUBDIRS = man
bin_PROGRAMS = xconsole
AM_CFLAGS = $(XCONSOLE_CFLAGS) $(CWARNFLAGS)
@@ -27,9 +28,6 @@ xconsole_LDADD = $(XCONSOLE_LIBS)
xconsole_SOURCES = \
xconsole.c
-appman_PRE = \
- xconsole.man
-
# App default files
DISTCHECK_CONFIGURE_FLAGS = --with-appdefaultdir=\$${datadir}/X11/app-defaults
@@ -38,20 +36,7 @@ appdefaultdir = @appdefaultdir@
dist_appdefault_DATA = \
app-defaults/XConsole
-
-appmandir = $(APP_MAN_DIR)
-
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-
-EXTRA_DIST = $(appman_PRE)
MAINTAINERCLEANFILES = ChangeLog INSTALL
-CLEANFILES = $(appman_DATA)
-
-SUFFIXES = .$(APP_MAN_SUFFIX) .man
-
-# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
.PHONY: ChangeLog INSTALL