summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-11-08 12:10:33 -0800
committerAnas Nashif <anas.nashif@intel.com>2012-11-08 12:10:33 -0800
commit4f1a42f85bb16d006429c7ce867be939a222fc25 (patch)
tree32c8299ffb94384006a2ef669a9a3d1d17aae5fe /src/Makefile.am
downloadxcb-proto-upstream/1.8.tar.gz
xcb-proto-upstream/1.8.tar.bz2
xcb-proto-upstream/1.8.zip
Imported Upstream version 1.8upstream/1.8
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..eef2dbc
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,36 @@
+xcbinclude_HEADERS = \
+ xcb.xsd \
+ xproto.xml \
+ bigreq.xml \
+ composite.xml \
+ damage.xml \
+ dpms.xml \
+ dri2.xml \
+ ge.xml \
+ glx.xml \
+ randr.xml \
+ record.xml \
+ render.xml \
+ res.xml \
+ screensaver.xml \
+ shape.xml \
+ shm.xml \
+ sync.xml \
+ xc_misc.xml \
+ xevie.xml \
+ xf86dri.xml \
+ xf86vidmode.xml \
+ xfixes.xml \
+ xinerama.xml \
+ xinput.xml \
+ xkb.xml \
+ xprint.xml \
+ xselinux.xml \
+ xtest.xml \
+ xv.xml \
+ xvmc.xml
+
+if HAVE_XMLLINT
+check-local:
+ $(XMLLINT) --noout --schema $(srcdir)/xcb.xsd $(srcdir)/*.xml
+endif