summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am229
1 files changed, 205 insertions, 24 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 5faac18..c8ad51a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,6 +1,6 @@
## DO NOT EDIT! GENERATED AUTOMATICALLY!
## Process this file with automake to produce Makefile.in.
-# Copyright (C) 2002-2013 Free Software Foundation, Inc.
+# Copyright (C) 2002-2014 Free Software Foundation, Inc.
#
# This file is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -21,7 +21,7 @@
# the same distribution terms as the rest of that program.
#
# Generated by gnulib-tool.
-# Reproduce by: gnulib-tool --import --dir=. --local-dir=gl --lib=libgnu --source-base=lib --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-conditional-dependencies --no-libtool --macro-prefix=gl accept alloca announce-gen base32 bind c-ctype clock-time close connect crypto/md5 crypto/sha1 fcntl ftello futimens getaddrinfo getopt-gnu getpass-gnu getpeername getsockname git-version-gen gnupload iconv iconv-h ioctl listen maintainer-makefile mbtowc mkdir mkostemp mkstemp pipe quote quotearg recv regex select send setsockopt sigpipe sigprocmask snprintf socket stdbool strcasestr strerror_r-posix strtok_r tmpdir unlocked-io update-copyright vasprintf vsnprintf write
+# Reproduce by: gnulib-tool --import --dir=. --local-dir=gl --lib=libgnu --source-base=lib --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-conditional-dependencies --no-libtool --macro-prefix=gl accept alloca announce-gen base32 bind c-ctype c-strcase clock-time close connect crypto/md5 crypto/sha1 fcntl fnmatch ftello futimens getaddrinfo getopt-gnu getpass-gnu getpeername getsockname git-version-gen gnupload iconv iconv-h ioctl listen maintainer-makefile mbiter mbtowc memrchr mkdir mkostemp mkstemp quote quotearg recv regex select send setsockopt sigpipe sigprocmask snprintf socket spawn-pipe stdbool strcase strerror_r-posix strptime strtok_r strtoll timegm tmpdir unlocked-io update-copyright vasprintf vsnprintf write xstrndup
AUTOMAKE_OPTIONS = 1.9.6 gnits subdir-objects
@@ -449,6 +449,32 @@ EXTRA_libgnu_a_SOURCES += float.c itold.c
## end gnulib module float
+## begin gnulib module fnmatch
+
+BUILT_SOURCES += $(FNMATCH_H)
+
+# We need the following in order to create <fnmatch.h> when the system
+# doesn't have one that supports the required API.
+if GL_GENERATE_FNMATCH_H
+fnmatch.h: fnmatch.in.h $(top_builddir)/config.status $(ARG_NONNULL_H)
+ $(AM_V_GEN)rm -f $@-t $@ && \
+ { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
+ sed -e '/definition of _GL_ARG_NONNULL/r $(ARG_NONNULL_H)' \
+ < $(srcdir)/fnmatch.in.h; \
+ } > $@-t && \
+ mv -f $@-t $@
+else
+fnmatch.h: $(top_builddir)/config.status
+ rm -f $@
+endif
+MOSTLYCLEANFILES += fnmatch.h fnmatch.h-t
+
+EXTRA_DIST += fnmatch.c fnmatch.in.h fnmatch_loop.c
+
+EXTRA_libgnu_a_SOURCES += fnmatch.c fnmatch_loop.c
+
+## end gnulib module fnmatch
+
## begin gnulib module fseek
@@ -706,6 +732,15 @@ EXTRA_libgnu_a_SOURCES += ioctl.c
## end gnulib module ioctl
+## begin gnulib module iswblank
+
+
+EXTRA_DIST += iswblank.c
+
+EXTRA_libgnu_a_SOURCES += iswblank.c
+
+## end gnulib module iswblank
+
## begin gnulib module langinfo
BUILT_SOURCES += langinfo.h
@@ -896,23 +931,28 @@ EXTRA_DIST += $(top_srcdir)/maint.mk
## end gnulib module maintainer-makefile
-## begin gnulib module malloc-gnu
+## begin gnulib module malloc-posix
EXTRA_DIST += malloc.c
EXTRA_libgnu_a_SOURCES += malloc.c
-## end gnulib module malloc-gnu
+## end gnulib module malloc-posix
-## begin gnulib module malloc-posix
+## begin gnulib module mbchar
+libgnu_a_SOURCES += mbchar.c
-EXTRA_DIST += malloc.c
+EXTRA_DIST += mbchar.h
-EXTRA_libgnu_a_SOURCES += malloc.c
+## end gnulib module mbchar
-## end gnulib module malloc-posix
+## begin gnulib module mbiter
+
+libgnu_a_SOURCES += mbiter.h mbiter.c
+
+## end gnulib module mbiter
## begin gnulib module mbrtowc
@@ -932,6 +972,15 @@ EXTRA_libgnu_a_SOURCES += mbsinit.c
## end gnulib module mbsinit
+## begin gnulib module mbsrtowcs
+
+
+EXTRA_DIST += mbsrtowcs-impl.h mbsrtowcs-state.c mbsrtowcs.c
+
+EXTRA_libgnu_a_SOURCES += mbsrtowcs-state.c mbsrtowcs.c
+
+## end gnulib module mbsrtowcs
+
## begin gnulib module mbtowc
@@ -950,6 +999,15 @@ EXTRA_libgnu_a_SOURCES += memchr.c
## end gnulib module memchr
+## begin gnulib module memrchr
+
+
+EXTRA_DIST += memrchr.c
+
+EXTRA_libgnu_a_SOURCES += memrchr.c
+
+## end gnulib module memrchr
+
## begin gnulib module mkdir
@@ -977,6 +1035,24 @@ EXTRA_libgnu_a_SOURCES += mkstemp.c
## end gnulib module mkstemp
+## begin gnulib module mktime
+
+
+EXTRA_DIST += mktime-internal.h mktime.c
+
+EXTRA_libgnu_a_SOURCES += mktime.c
+
+## end gnulib module mktime
+
+## begin gnulib module mktime-internal
+
+
+EXTRA_DIST += mktime-internal.h mktime.c
+
+EXTRA_libgnu_a_SOURCES += mktime.c
+
+## end gnulib module mktime-internal
+
## begin gnulib module msvc-inval
@@ -1085,13 +1161,6 @@ EXTRA_DIST += pathmax.h
## end gnulib module pathmax
-## begin gnulib module pipe
-
-
-EXTRA_DIST += pipe.h
-
-## end gnulib module pipe
-
## begin gnulib module pipe2
libgnu_a_SOURCES += pipe2.c
@@ -1877,6 +1946,7 @@ stdlib.h: stdlib.in.h $(top_builddir)/config.status $(CXXDEFS_H) \
-e 's/@''GNULIB_PTSNAME''@/$(GNULIB_PTSNAME)/g' \
-e 's/@''GNULIB_PTSNAME_R''@/$(GNULIB_PTSNAME_R)/g' \
-e 's/@''GNULIB_PUTENV''@/$(GNULIB_PUTENV)/g' \
+ -e 's/@''GNULIB_QSORT_R''@/$(GNULIB_QSORT_R)/g' \
-e 's/@''GNULIB_RANDOM''@/$(GNULIB_RANDOM)/g' \
-e 's/@''GNULIB_RANDOM_R''@/$(GNULIB_RANDOM_R)/g' \
-e 's/@''GNULIB_REALLOC_POSIX''@/$(GNULIB_REALLOC_POSIX)/g' \
@@ -1928,6 +1998,7 @@ stdlib.h: stdlib.in.h $(top_builddir)/config.status $(CXXDEFS_H) \
-e 's|@''REPLACE_PTSNAME''@|$(REPLACE_PTSNAME)|g' \
-e 's|@''REPLACE_PTSNAME_R''@|$(REPLACE_PTSNAME_R)|g' \
-e 's|@''REPLACE_PUTENV''@|$(REPLACE_PUTENV)|g' \
+ -e 's|@''REPLACE_QSORT_R''@|$(REPLACE_QSORT_R)|g' \
-e 's|@''REPLACE_RANDOM_R''@|$(REPLACE_RANDOM_R)|g' \
-e 's|@''REPLACE_REALLOC''@|$(REPLACE_REALLOC)|g' \
-e 's|@''REPLACE_REALPATH''@|$(REPLACE_REALPATH)|g' \
@@ -1956,15 +2027,6 @@ EXTRA_libgnu_a_SOURCES += strcasecmp.c strncasecmp.c
## end gnulib module strcase
-## begin gnulib module strcasestr-simple
-
-
-EXTRA_DIST += str-two-way.h strcasestr.c
-
-EXTRA_libgnu_a_SOURCES += strcasestr.c
-
-## end gnulib module strcasestr-simple
-
## begin gnulib module strchrnul
@@ -2139,6 +2201,39 @@ EXTRA_DIST += strings.in.h
## end gnulib module strings
+## begin gnulib module strndup
+
+
+EXTRA_DIST += strndup.c
+
+EXTRA_libgnu_a_SOURCES += strndup.c
+
+## end gnulib module strndup
+
+## begin gnulib module strnlen
+
+
+EXTRA_DIST += strnlen.c
+
+EXTRA_libgnu_a_SOURCES += strnlen.c
+
+## end gnulib module strnlen
+
+## begin gnulib module strnlen1
+
+libgnu_a_SOURCES += strnlen1.h strnlen1.c
+
+## end gnulib module strnlen1
+
+## begin gnulib module strptime
+
+
+EXTRA_DIST += strptime.c
+
+EXTRA_libgnu_a_SOURCES += strptime.c
+
+## end gnulib module strptime
+
## begin gnulib module strtok_r
@@ -2148,6 +2243,15 @@ EXTRA_libgnu_a_SOURCES += strtok_r.c
## end gnulib module strtok_r
+## begin gnulib module strtoll
+
+
+EXTRA_DIST += strtol.c strtoll.c
+
+EXTRA_libgnu_a_SOURCES += strtol.c strtoll.c
+
+## end gnulib module strtoll
+
## begin gnulib module sys_ioctl
BUILT_SOURCES += sys/ioctl.h
@@ -2502,6 +2606,24 @@ EXTRA_DIST += time.in.h
## end gnulib module time
+## begin gnulib module time_r
+
+
+EXTRA_DIST += time_r.c
+
+EXTRA_libgnu_a_SOURCES += time_r.c
+
+## end gnulib module time_r
+
+## begin gnulib module timegm
+
+
+EXTRA_DIST += mktime-internal.h timegm.c
+
+EXTRA_libgnu_a_SOURCES += timegm.c
+
+## end gnulib module timegm
+
## begin gnulib module timespec
libgnu_a_SOURCES += timespec.c
@@ -2647,9 +2769,11 @@ unistd.h: unistd.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNULL_H
-e 's|@''REPLACE_PWRITE''@|$(REPLACE_PWRITE)|g' \
-e 's|@''REPLACE_READ''@|$(REPLACE_READ)|g' \
-e 's|@''REPLACE_READLINK''@|$(REPLACE_READLINK)|g' \
+ -e 's|@''REPLACE_READLINKAT''@|$(REPLACE_READLINKAT)|g' \
-e 's|@''REPLACE_RMDIR''@|$(REPLACE_RMDIR)|g' \
-e 's|@''REPLACE_SLEEP''@|$(REPLACE_SLEEP)|g' \
-e 's|@''REPLACE_SYMLINK''@|$(REPLACE_SYMLINK)|g' \
+ -e 's|@''REPLACE_SYMLINKAT''@|$(REPLACE_SYMLINKAT)|g' \
-e 's|@''REPLACE_TTYNAME_R''@|$(REPLACE_TTYNAME_R)|g' \
-e 's|@''REPLACE_UNLINK''@|$(REPLACE_UNLINK)|g' \
-e 's|@''REPLACE_UNLINKAT''@|$(REPLACE_UNLINKAT)|g' \
@@ -2676,6 +2800,48 @@ EXTRA_DIST += unistd--.h unistd-safer.h
## end gnulib module unistd-safer
+## begin gnulib module unitypes
+
+BUILT_SOURCES += $(LIBUNISTRING_UNITYPES_H)
+
+unitypes.h: unitypes.in.h
+ $(AM_V_GEN)rm -f $@-t $@ && \
+ { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
+ cat $(srcdir)/unitypes.in.h; \
+ } > $@-t && \
+ mv -f $@-t $@
+MOSTLYCLEANFILES += unitypes.h unitypes.h-t
+
+EXTRA_DIST += unitypes.in.h
+
+## end gnulib module unitypes
+
+## begin gnulib module uniwidth/base
+
+BUILT_SOURCES += $(LIBUNISTRING_UNIWIDTH_H)
+
+uniwidth.h: uniwidth.in.h
+ $(AM_V_GEN)rm -f $@-t $@ && \
+ { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
+ cat $(srcdir)/uniwidth.in.h; \
+ } > $@-t && \
+ mv -f $@-t $@
+MOSTLYCLEANFILES += uniwidth.h uniwidth.h-t
+
+EXTRA_DIST += localcharset.h uniwidth.in.h
+
+## end gnulib module uniwidth/base
+
+## begin gnulib module uniwidth/width
+
+if LIBUNISTRING_COMPILE_UNIWIDTH_WIDTH
+libgnu_a_SOURCES += uniwidth/width.c
+endif
+
+EXTRA_DIST += uniwidth/cjk.h
+
+## end gnulib module uniwidth/width
+
## begin gnulib module unlocked-io
@@ -2931,6 +3097,15 @@ EXTRA_DIST += wctype.in.h
## end gnulib module wctype-h
+## begin gnulib module wcwidth
+
+
+EXTRA_DIST += wcwidth.c
+
+EXTRA_libgnu_a_SOURCES += wcwidth.c
+
+## end gnulib module wcwidth
+
## begin gnulib module write
@@ -2967,6 +3142,12 @@ libgnu_a_SOURCES += xsize.h xsize.c
## end gnulib module xsize
+## begin gnulib module xstrndup
+
+libgnu_a_SOURCES += xstrndup.h xstrndup.c
+
+## end gnulib module xstrndup
+
mostlyclean-local: mostlyclean-generic
@for dir in '' $(MOSTLYCLEANDIRS); do \