summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 13 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 167882f..53cf142 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Template file for GNU Autoconf
-dnl Copyright (C) 1995-1997, 2001, 2007-2014, 2018 Free Software
+dnl Copyright (C) 1995-1997, 2001, 2007-2014, 2018-2019 Free Software
dnl Foundation, Inc.
dnl This program is free software; you can redistribute it and/or modify
@@ -51,7 +51,7 @@ dnl
AM_INIT_AUTOMAKE([1.9])
dnl
-dnl Get cannonical host
+dnl Get canonical host
dnl
AC_CANONICAL_HOST
AC_DEFINE_UNQUOTED([OS_TYPE], "$host_os",
@@ -103,6 +103,15 @@ AC_ARG_ENABLE([fuzzing],
#AC_SUBST([FUZZ_LIBS])
AM_CONDITIONAL([FUZZING], [test "$enable_fuzzing" = "yes"])
+dnl needed for some fuzzers
+OLD_LIBS="$LIBS"
+AC_SEARCH_LIBS([dlopen], [dl dld])
+if [[ "${ac_cv_search_dlopen#-l}" != "${ac_cv_search_dlopen}" ]]; then
+ FUZZ_LIBS="${ac_cv_search_dlopen}"
+ AC_SUBST([FUZZ_LIBS])
+fi
+LIBS="$OLD_LIBS"
+
dnl Opie: Support for opie s/key FTP logins
AC_ARG_ENABLE([opie],
[AS_HELP_STRING([--disable-opie], [disable support for opie or s/key FTP login])],
@@ -281,7 +290,8 @@ AC_CHECK_TYPES(sig_atomic_t, [], [], [
#include <signal.h>
])
-# gnulib
+# gnulib, AM_ICONV should be placed before gl_INIT
+AM_ICONV
gl_INIT
dnl
@@ -618,8 +628,6 @@ AC_ARG_ENABLE(iri,
)
AS_IF([test "X$iri" != "Xno"],[
- AM_ICONV
-
if test "X$am_cv_func_iconv" != "Xyes"; then
iri=no
if test "X$force_iri" = "Xyes"; then