summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDongHun Kwak <dh0128.kwak@samsung.com>2021-03-05 10:06:12 +0900
committerDongHun Kwak <dh0128.kwak@samsung.com>2021-03-05 10:06:12 +0900
commit1d8b652baba3df2da0eb42560205cab2ccb360e9 (patch)
treec546e30de11fdb2d144057d59b9c0d5f0f2539d5 /configure.ac
parent81f1c64e30d2ea59604a628bca9f1d04b1f82afb (diff)
downloadwget-1d8b652baba3df2da0eb42560205cab2ccb360e9.tar.gz
wget-1d8b652baba3df2da0eb42560205cab2ccb360e9.tar.bz2
wget-1d8b652baba3df2da0eb42560205cab2ccb360e9.zip
Imported Upstream version 1.14upstream/1.14
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 38 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 76c6fa2..873c3c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,7 @@ dnl Process this file with autoconf to produce a configure script.
dnl
AC_INIT([wget],
- [m4_esyscmd([build-aux/bzr-version-gen])],
+ m4_esyscmd([build-aux/git-version-gen .tarball-version]),
[bug-wget@gnu.org])
AC_PREREQ(2.61)
@@ -65,6 +65,9 @@ AC_ARG_WITH(ssl,
[[ --without-ssl disable SSL autodetection
--with-ssl={gnutls,openssl} specify the SSL backend. GNU TLS is the default.]])
+AC_ARG_WITH(zlib,
+[[ --without-zlib disable zlib ]])
+
AC_ARG_ENABLE(opie,
[ --disable-opie disable support for opie or s/key FTP login],
ENABLE_OPIE=$enableval, ENABLE_OPIE=yes)
@@ -234,6 +237,10 @@ dnl
dnl Checks for libraries.
dnl
+AS_IF([test x"$with_zlib" != xno], [
+ AC_CHECK_LIB(z, compress)
+])
+
AS_IF([test x"$with_ssl" = xopenssl], [
dnl some versions of openssl use zlib compression
AC_CHECK_LIB(z, compress)
@@ -257,6 +264,9 @@ AS_IF([test x"$with_ssl" = xopenssl], [
AC_CHECK_LIB(ssl32, SSL_connect, [
ssl_found=yes
AC_MSG_NOTICE([Enabling support for SSL via OpenSSL (shared)])
+ AC_LIBOBJ([openssl])
+ LIBS="${LIBS} -lssl32"
+ AC_DEFINE([HAVE_LIBSSL32], [1], [Define to 1 if you have the `ssl32' library (-lssl32).])
],
AC_MSG_ERROR([openssl not found: shared lib eay32 found but ssl32 not found]))
@@ -282,6 +292,7 @@ AS_IF([test x$ssl_found != xyes],
], [SSL_library_init ()])
if test x"$LIBSSL" != x
then
+ ssl_found=yes
AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
AC_LIBOBJ([openssl])
LIBS="$LIBSSL $LIBS"
@@ -289,9 +300,6 @@ AS_IF([test x$ssl_found != xyes],
then
AC_MSG_ERROR([--with-ssl=openssl was given, but SSL is not available.])
fi
-
- AC_LIBOBJ([openssl])
-
])
], [
@@ -309,6 +317,7 @@ AS_IF([test x$ssl_found != xyes],
], [gnutls_global_init()])
if test x"$LIBGNUTLS" != x
then
+ ssl_found=yes
AC_MSG_NOTICE([compiling in support for SSL via GnuTLS])
AC_LIBOBJ([gnutls])
LIBS="$LIBGNUTLS $LIBS"
@@ -321,7 +330,7 @@ AS_IF([test x$ssl_found != xyes],
]) # endif: --with-ssl == openssl?
dnl Enable NTLM if requested and if SSL is available.
-if test x"$LIBSSL" != x
+if test x"$LIBSSL" != x || test "$ac_cv_lib_ssl32_SSL_connect" = yes
then
if test x"$ENABLE_NTLM" != xno
then
@@ -511,7 +520,31 @@ if test "X$iri" != "Xno"; then
fi
fi
+dnl
+dnl Check for UUID
+dnl
+
+AC_CHECK_HEADER(uuid/uuid.h,
+ AC_CHECK_LIB(uuid, uuid_generate,
+ [LIBS="${LIBS} -luuid"
+ AC_DEFINE([HAVE_LIBUUID], 1,
+ [Define if libuuid is available.])
+ ])
+)
+
+dnl
+dnl Check for PCRE
+dnl
+
+AC_CHECK_HEADER(pcre.h,
+ AC_CHECK_LIB(pcre, pcre_compile,
+ [LIBS="${LIBS} -lpcre"
+ AC_DEFINE([HAVE_LIBPCRE], 1,
+ [Define if libpcre is available.])
+ ])
+)
+
dnl Needed by src/Makefile.am
AM_CONDITIONAL([IRI_IS_ENABLED], [test "X$iri" != "Xno"])