summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArmin K <krejzi@email.com>2013-07-14 17:26:23 +0200
committerKristian Høgsberg <krh@bitplanet.net>2013-08-20 15:43:40 -0700
commit8cb42738aff47144d4a5f144f8ecaf0ee3f4b605 (patch)
tree72f2bd8ef03c51ccbd14581907194eabbd17b31e /configure.ac
parente9afc57787eb139a31a5b1356b4407d63e279ab9 (diff)
downloadweston-8cb42738aff47144d4a5f144f8ecaf0ee3f4b605.tar.gz
weston-8cb42738aff47144d4a5f144f8ecaf0ee3f4b605.tar.bz2
weston-8cb42738aff47144d4a5f144f8ecaf0ee3f4b605.zip
autotools: Add an option to install demo clients
This patch adds a configure option which will enable user to install demo clients if desired. It is disabled by default. v2: Remove AC_DEFINE as it is not necesary
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5b110e0c..f9f1c538 100644
--- a/configure.ac
+++ b/configure.ac
@@ -383,6 +383,12 @@ AC_MSG_NOTICE([Weston's native backend: $WESTON_NATIVE_BACKEND])
AC_DEFINE_UNQUOTED([WESTON_NATIVE_BACKEND], ["$WESTON_NATIVE_BACKEND"],
[The default backend to load, if not wayland nor x11.])
+AC_ARG_ENABLE(demo-clients,
+ AS_HELP_STRING([--enable-demo-clients],
+ [install demo clients built with weston]),,
+ enable_demo_clients=no)
+AM_CONDITIONAL(ENABLE_DEMO_CLIENTS, [test "x$enable_demo_clients" = "xyes"])
+
PKG_CHECK_MODULES(LCMS, lcms2,
[have_lcms=yes], [have_lcms=no])
if test "x$have_lcms" = xyes; then