summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Bradford <rob@linux.intel.com>2013-06-04 13:23:01 +0100
committerKristian Høgsberg <krh@bitplanet.net>2013-06-04 23:11:42 -0400
commit5a4cea9a9c35ba8c8dd9ee0baebc040c8cbb0561 (patch)
tree9df4b5f5b631732042265e98b305d48be60e22fc /configure.ac
parent1cc5ac34b5eaaa3398e6e2fc77ab9b1dc7878a25 (diff)
downloadweston-5a4cea9a9c35ba8c8dd9ee0baebc040c8cbb0561.tar.gz
weston-5a4cea9a9c35ba8c8dd9ee0baebc040c8cbb0561.tar.bz2
weston-5a4cea9a9c35ba8c8dd9ee0baebc040c8cbb0561.zip
build: Add declaration checks to check for required syscall flags
The required flags are relatively new and some older enterprise distributions do not feature them. https://bugs.freedesktop.org/show_bug.cgi?id=63360
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ba1fcac7..848ff926 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,15 @@ AC_CHECK_FUNC([dlopen], [],
AC_CHECK_LIB([dl], [dlopen], DLOPEN_LIBS="-ldl"))
AC_SUBST(DLOPEN_LIBS)
+AC_CHECK_DECL(SFD_CLOEXEC,[],
+ [AC_MSG_ERROR("SFD_CLOEXEC is needed to compile weston")],
+ [[#include <sys/signalfd.h>]])
+AC_CHECK_DECL(TFD_CLOEXEC,[],
+ [AC_MSG_ERROR("TFD_CLOEXEC is needed to compile weston")],
+ [[#include <sys/timerfd.h>]])
+AC_CHECK_DECL(CLOCK_MONOTONIC,[],
+ [AC_MSG_ERROR("CLOCK_MONOTONIC is needed to compile weston")],
+ [[#include <time.h>]])
AC_CHECK_HEADERS([execinfo.h])
AC_CHECK_FUNCS([mkostemp strchrnul])