summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDongHun Kwak <dh0128.kwak@samsung.com>2023-05-17 16:16:16 +0900
committerDongHun Kwak <dh0128.kwak@samsung.com>2023-05-17 16:16:16 +0900
commita56aafc610b5a5112b48320f9532ff3da969eb2f (patch)
tree7e6cc4da83f6bfd1c56a6f565064a8cd6251bbaa /Cargo.toml
downloadrust-simdutf8-upstream.tar.gz
rust-simdutf8-upstream.tar.bz2
rust-simdutf8-upstream.zip
Import simdutf8 0.1.4upstream/0.1.4upstream
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml65
1 files changed, 65 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..a605041
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,65 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "simdutf8"
+version = "0.1.4"
+authors = ["Hans Kratz <hans@appfour.com>"]
+exclude = [
+ "/.gitignore",
+ "/.github",
+ "/.vscode",
+ "/bench",
+ "/fuzzing",
+ "/img",
+ "/inlining",
+ "TODO.md",
+]
+description = "SIMD-accelerated UTF-8 validation."
+homepage = "https://github.com/rusticstuff/simdutf8"
+documentation = "https://docs.rs/simdutf8/"
+readme = "README.md"
+keywords = [
+ "utf-8",
+ "unicode",
+ "string",
+ "validation",
+ "simd",
+]
+categories = [
+ "encoding",
+ "algorithms",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rusticstuff/simdutf8"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+default-target = "x86_64-unknown-linux-gnu"
+targets = [
+ "aarch64-unknown-linux-gnu",
+ "wasm32-unknown-unknown",
+ "wasm32-wasi",
+]
+
+[features]
+aarch64_neon = []
+aarch64_neon_prefetch = []
+default = ["std"]
+hints = []
+public_imp = []
+std = []