summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9d8b4827..6ffd78eb 100644
--- a/configure.in
+++ b/configure.in
@@ -56,6 +56,13 @@ main() { long long x = 1000000; char b[20]; x *= x; sprintf(b,"%lld", x); exit(s
echo yes;AC_DEFINE(HAVE_LONGLONG),
echo no)
+echo $ac_n "checking for off64_t ... $ac_c"
+AC_TRY_RUN([#include <stdio.h>
+#include <sys/stat.h>
+main() { struct stat64 st; off64_t s; exit((lstat64("/dev/null", &st)==0)?0:1); }],
+echo yes;AC_DEFINE(HAVE_LONGLONG),
+echo no)
+
echo $ac_n "checking for utimbuf ... $ac_c"
AC_TRY_COMPILE([#include <sys/types.h>
#include <utime.h>],