summaryrefslogtreecommitdiff
path: root/packaging/rpm.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/rpm.spec')
-rw-r--r--packaging/rpm.spec11
1 files changed, 11 insertions, 0 deletions
diff --git a/packaging/rpm.spec b/packaging/rpm.spec
index 9bb1322fe..497b9a21a 100644
--- a/packaging/rpm.spec
+++ b/packaging/rpm.spec
@@ -253,6 +253,17 @@ rm -f %{_dbpath}/Filemd5s \
%{_dbpath}/Requireversion \
%{_dbpath}/Provideversion
+%ifarch armv7l
+sed -e s/armv7l-tizen-linux-gnueabi/armv7hl-tizen-linux-gnueabihf/g -i /usr/lib/rpm/macros
+sed -e s/armv7l/armv7hl/g -i /usr/lib/rpm/macros
+%endif
+
+%post build
+%ifarch armv7l
+sed -e s/armv7l-tizen-linux-gnueabi/armv7hl-tizen-linux-gnueabihf/g -i /usr/lib/rpm/macros
+sed -e s/armv7l/armv7hl/g -i /usr/lib/rpm/macros
+%endif
+
%postun
/sbin/ldconfig