summaryrefslogtreecommitdiff
path: root/rpmdb/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2007-12-03 10:47:25 +0200
committerPanu Matilainen <pmatilai@redhat.com>2007-12-03 10:47:25 +0200
commita96f817d50953f0fd48bd2a7bb983c82256bbc78 (patch)
tree4337083494c9643c76b71717fabc35365dd72753 /rpmdb/Makefile.am
parent6bdbbefbecf06b75581b8dfbd4ea626c59ebe312 (diff)
downloadrpm-a96f817d50953f0fd48bd2a7bb983c82256bbc78.tar.gz
rpm-a96f817d50953f0fd48bd2a7bb983c82256bbc78.tar.bz2
rpm-a96f817d50953f0fd48bd2a7bb983c82256bbc78.zip
Split RPMTAG_* and related functions out of rpmlib.h to rpmtag.h
Diffstat (limited to 'rpmdb/Makefile.am')
-rw-r--r--rpmdb/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/rpmdb/Makefile.am b/rpmdb/Makefile.am
index e8a16c4de..e83924613 100644
--- a/rpmdb/Makefile.am
+++ b/rpmdb/Makefile.am
@@ -37,13 +37,14 @@ else
librpmdb_la_LIBADD += @WITH_DB_LIB@
endif
-tagtbl.c: Makefile.am $(top_srcdir)/lib/rpmlib.h
+tagtbl.c: Makefile.am $(top_srcdir)/lib/rpmtag.h
@echo '#include "system.h"' > $@
- @echo '#include <rpmlib.h>' >> $@
+ @echo '#include <header.h>' >> $@
+ @echo '#include <rpmtag.h>' >> $@
@echo '#include "debug.h"' >> $@
@echo '' >> $@
@echo 'static const struct headerTagTableEntry_s rpmTagTbl[] = {' >> $@
- ${AWK} '/(RPMTAG_[A-Z0-9]*)[ \t]+([0-9]*)/ && !/internal/ {tt = "NULL"; ta = "ANY"; if ($$5 == "c") {tt = "CHAR"; ta = "SCALAR"} if ($$5 == "c[]") {tt = "CHAR"; ta = "ARRAY"} if ($$5 == "h") {tt = "INT16"; ta = "SCALAR"} if ($$5 == "h[]") {tt = "INT16"; ta = "ARRAY"} if ($$5 == "i") {tt = "INT32"; ta = "SCALAR"} if ($$5 == "i[]") {tt = "INT32"; ta = "ARRAY"} if ($$5 == "l") {tt = "INT64"; ta = "SCALAR"} if ($$5 == "l[]") {tt = "INT64"; ta = "ARRAY"} if ($$5 == "s") {tt = "STRING"; ta = "SCALAR"} if ($$5 == "s[]") {tt = "STRING_ARRAY"; ta = "ARRAY"} if ($$5 == "s{}") {tt = "I18NSTRING"; ta = "SCALAR"} if ($$5 == "x") {tt = "BIN"; ta = "SCALAR"} if ($$2 == "=") { printf("\t{ \"%s\", %s RPM_%s_TYPE + RPM_%s_RETURN_TYPE },\n", $$1, $$3, tt, ta) } else { printf("\t{ \"%s\", %s, RPM_%s_TYPE + RPM_%s_RETURN_TYPE },\n", $$2, $$3, tt, ta) } }' < ${top_srcdir}/lib/rpmlib.h | sort >> $@
+ ${AWK} '/[\t ](RPMTAG_[A-Z0-9]*)[ \t]+([0-9]*)/ && !/internal/ {tt = "NULL"; ta = "ANY"; if ($$5 == "c") {tt = "CHAR"; ta = "SCALAR"} if ($$5 == "c[]") {tt = "CHAR"; ta = "ARRAY"} if ($$5 == "h") {tt = "INT16"; ta = "SCALAR"} if ($$5 == "h[]") {tt = "INT16"; ta = "ARRAY"} if ($$5 == "i") {tt = "INT32"; ta = "SCALAR"} if ($$5 == "i[]") {tt = "INT32"; ta = "ARRAY"} if ($$5 == "l") {tt = "INT64"; ta = "SCALAR"} if ($$5 == "l[]") {tt = "INT64"; ta = "ARRAY"} if ($$5 == "s") {tt = "STRING"; ta = "SCALAR"} if ($$5 == "s[]") {tt = "STRING_ARRAY"; ta = "ARRAY"} if ($$5 == "s{}") {tt = "I18NSTRING"; ta = "SCALAR"} if ($$5 == "x") {tt = "BIN"; ta = "SCALAR"} if ($$2 == "=") { printf("\t{ \"%s\", %s RPM_%s_TYPE + RPM_%s_RETURN_TYPE },\n", $$1, $$3, tt, ta) } else { printf("\t{ \"%s\", %s, RPM_%s_TYPE + RPM_%s_RETURN_TYPE },\n", $$2, $$3, tt, ta) } }' < ${top_srcdir}/lib/rpmtag.h | sort >> $@
@echo ' { NULL, 0, 0 }' >> $@
@echo '};' >> $@
@echo '' >> $@