summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2010-01-04 13:46:43 +0200
committerPanu Matilainen <pmatilai@redhat.com>2010-01-04 13:46:43 +0200
commit60dc809db136e8bba12a9d45e189248218e304cb (patch)
tree2e3a52b0e6f88b9893763683114a42b3030938d0 /configure.ac
parent216cf2acb664e8d7f8a47857a942adba43d0fec2 (diff)
downloadrpm-60dc809db136e8bba12a9d45e189248218e304cb.tar.gz
rpm-60dc809db136e8bba12a9d45e189248218e304cb.tar.bz2
rpm-60dc809db136e8bba12a9d45e189248218e304cb.zip
Eliminate myrealloc() replacement function
- realloc(NULL, size) is defined as equal to malloc(size) in C99 and POSIX 2001, we dont care about anything older than that
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 0 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 92001b271..d6da981b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -812,8 +812,6 @@ elif echo "$host_os" | grep sunos > /dev/null; then
echo "hacking things up for sunos"
CFLAGS="$CFLAGS -D__USE_FIXED_PROTOTYPES__"
AC_DEFINE(NEED_STRINGS_H, 1, [Define as one if we need to include <strings.h> (along with <string.h>)])
- AC_DEFINE(NEED_MYREALLOC, 1, [Define as 1 if we need myrealloc])
- AC_LIBOBJ(myrealloc)
fi
#