summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5ec3f04f..017691d4 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,8 @@ BUILT_SOURCES = parser.cc scanner.cc
#CXXFLAGS = -O2 -Wall -Wno-unused -Wno-parentheses -Wno-deprecated
#CXXFLAGS = -ggdb -fno-inline -O2 -Wall -Wextra -pedantic -Wconversion -Wpointer-arith -Wwrite-strings -Wredundant-decls -Werror -Wunused-function -DPEDANTIC
-CXXFLAGS = -W -Wall -Wextra -pedantic -Wredundant-decls -DPEDANTIC -O2 -g
+#CXXFLAGS += -O2
+CXXFLAGS += -W -Wall -Wextra -pedantic -Wredundant-decls -DPEDANTIC
YFLAGS = -d
RE2C = re2c$(EXEEXT)
@@ -23,8 +24,11 @@ CLEANFILES = parser.cc y.tab.c y.tab.h scanner.cc re2c.1 .version htdocs/manua
DISTCLEANFILES = makerpm re2c.spec README scanner.cc re2c$(EXEEXT)
+man_MANS = re2c.1
+
EXTRA_SRC = README parser.y scanner.re y.tab.h CHANGELOG NO_WARRANTY \
- doc examples test bootstrap/*.cc bootstrap/*.h lessons
+ doc examples test bootstrap/*.cc bootstrap/*.h lessons \
+ $(man_MANS) $(DOCS_IN) $(DOCS_GEN)
EXTRA_DIST = $(EXTRA_SRC) makerpm.in re2c.spec.in re2c.spec README.in config_w32.h.in
EXTRA_ZIP = $(EXTRA_SRC) config_w32.h *.sln *.vcproj re2c.rules