summaryrefslogtreecommitdiff
path: root/packaging/re2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/re2.spec')
-rw-r--r--packaging/re2.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/packaging/re2.spec b/packaging/re2.spec
new file mode 100644
index 0000000..81ef735
--- /dev/null
+++ b/packaging/re2.spec
@@ -0,0 +1,85 @@
+#
+# spec file for package python-compizconfig
+#
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2013 Intel Corporation.
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+
+Name: re2
+Version: 20200801
+Release: 1
+License: BSD-3-Clause
+Summary: An efficient, principled regular expression library
+Url: http://code.google.com/p/re2/
+Group: System/Libraries
+Source: re2-%{version}.tgz
+Source1001: %{name}.manifest
+BuildRequires: gcc-c++
+
+%description
+RE2 is a fast, safe, thread-friendly alternative to backtracking
+regular expression engines like those used in PCRE, Perl, and
+Python. It is a C++ library.
+
+
+%package -n libre2
+License: BSD-2.0
+Summary: An efficient, principled regular expression library
+Group: System/Libraries
+
+%description -n libre2
+RE2 is a fast, safe, thread-friendly alternative to backtracking
+regular expression engines like those used in PCRE, Perl, and
+Python. It is a C++ library.
+
+
+%package devel
+License: BSD-2.0
+Summary: An efficient, principled regular expression library
+Group: System/Libraries
+Requires: libre2 = %{version}
+
+%description devel
+RE2 is a fast, safe, thread-friendly alternative to backtracking
+regular expression engines like those used in PCRE, Perl, and
+Python. It is a C++ library.
+
+
+%prep
+%setup -q -n re2
+cp %{SOURCE1001} .
+
+%build
+make %{?_smp_mflags} CXXFLAGS="$RPM_OPT_FLAGS -Wall -pthread" libdir=%{_libdir} prefix=%{_prefix}
+
+%install
+make DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir} prefix=%{_prefix} install
+rm $RPM_BUILD_ROOT%{_libdir}/libre2.a
+
+%remove_docs
+
+%post -n libre2 -p /sbin/ldconfig
+
+%postun -n libre2 -p /sbin/ldconfig
+
+
+%files -n libre2
+%manifest %{name}.manifest
+%license LICENSE
+%{_libdir}/libre2.so.8
+%{_libdir}/libre2.so.8.0.0
+
+
+%files devel
+%manifest %{name}.manifest
+%{_includedir}/re2
+%{_libdir}/libre2.so
+%{_libdir}/pkgconfig/re2.pc