summaryrefslogtreecommitdiff
path: root/packaging/qt5.spec
diff options
context:
space:
mode:
authorMyungJoo Ham <myungjoo.ham@samsung.com>2016-08-29 16:23:30 +0900
committerMyungJoo Ham <myungjoo.ham@samsung.com>2016-08-29 16:23:30 +0900
commit4eb2d77f1f9b6d1c3eb982e0f9190b9c6d06109d (patch)
tree41baf14b65bbd3c3ece77566ae10890ba356a21f /packaging/qt5.spec
parent27f4a93f217c74b7dd32f73858253b1368c2d41f (diff)
downloadqtbase-4eb2d77f1f9b6d1c3eb982e0f9190b9c6d06109d.tar.gz
qtbase-4eb2d77f1f9b6d1c3eb982e0f9190b9c6d06109d.tar.bz2
qtbase-4eb2d77f1f9b6d1c3eb982e0f9190b9c6d06109d.zip
Remove unnecessary profile build dependencies.
1. Removed Tizen < 3 check because this branch is for Tizen 3 + only 2. Modified to use the "_with_emulator" macro that is supplied by OBS 3. Removed "common" for non-NEON REVIEWERS: please double check this one 4. Removed "TIZEN_PROFILE" device option because grep -r "TIZEN_PROFILE" * showed NOTHING. Change-Id: Ieb799cde1223497888efdb36e1c47aba6843bff8 Signed-off-by: MyungJoo Ham <myungjoo.ham@samsung.com>
Diffstat (limited to 'packaging/qt5.spec')
-rw-r--r--packaging/qt5.spec24
1 files changed, 1 insertions, 23 deletions
diff --git a/packaging/qt5.spec b/packaging/qt5.spec
index 5b759105d8..9f97328552 100644
--- a/packaging/qt5.spec
+++ b/packaging/qt5.spec
@@ -29,25 +29,8 @@
# installed-but-unpackaged static libs.
# This flag tells rpmbuild to behave.
-%if "%{tizen_version_major}" < "3"
-%define profile mobile
-%define _with_x 1
-%define xkb_config_root -xkb-config-root /etc/X11/xkb
-%define _force_eglx 1
-%ifnarch armv7l armv7el
-%define _tizen_emulator 1
-%endif
-%else
-%if "%{_repository}" == "emulator"
-%define _tizen_emulator 1
-%endif
%define _with_xkbcommon 1
%define xkb_config_root %{nil}
-%endif
-
-%if "%{profile}" != "wearable" && "%{tizen_version_major}" < "3"
-%define _with_cups 1
-%endif
%bcond_with tizenscim
%bcond_with xkbcommon
@@ -599,12 +582,10 @@ This package contains the Qt5 development defaults package
cp %{SOURCE1001} .
touch .git
-%if "%{profile}" == "common"
%ifarch %arm armv7l %{aarch64}
export CFLAGS="$(echo $CFLAGS| sed 's/-mfpu=neon//gi')"
export CXXFLAGS="$(echo $CXXFLAGS| sed 's/-mfpu=neon//gi')"
%endif
-%endif
%ifarch %arm armv7l %{aarch64}
unset CFLAGS CXXFLAGS LFLAGS
@@ -618,15 +599,12 @@ MAKEFLAGS=%{?_smp_mflags} \
-no-warnings-are-errors \
%endif
-platform linux-g++-tizen \
-%if "%{profile}" != ""
- -device-option TIZEN_PROFILE=%{profile} \
-%if 0%{?_tizen_emulator:1}
+%if 0%{?_with_emulator:1}
-device-option TIZEN_EMULATOR=1 \
%endif
%if %{with tizenscim}
-device-option DEFINES+=TIZEN_SCIM=1 \
%endif
-%endif
%if %{with wayland}
-qpa wayland \
%else