summaryrefslogtreecommitdiff
path: root/packaging/qemu-linux-user.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/qemu-linux-user.spec')
-rw-r--r--packaging/qemu-linux-user.spec194
1 files changed, 194 insertions, 0 deletions
diff --git a/packaging/qemu-linux-user.spec b/packaging/qemu-linux-user.spec
new file mode 100644
index 000000000..3fc4941cd
--- /dev/null
+++ b/packaging/qemu-linux-user.spec
@@ -0,0 +1,194 @@
+#
+# spec file for package qemu-linux-user
+#
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
+
+
+Name: qemu-linux-user
+Url: http://www.qemu.org/
+Summary: Universal CPU emulator
+License: BSD-3-Clause and GPL-2.0 and GPL-2.0+ and LGPL-2.1+ and MIT
+Group: System/Emulators/PC
+Version: 2.7.0
+Release: 0
+Source: http://wiki.qemu.org/download/qemu-2.7.0.tar.bz2
+Source300: qemu-rpmlintrc
+Source400: update_git.sh
+BuildRoot: %{_tmppath}/%{name}-%{version}-build
+BuildRequires: e2fsprogs-devel
+BuildRequires: fdupes
+BuildRequires: gcc-c++
+%if 0%{?suse_version} >= 1140
+BuildRequires: glib2-devel-static
+%else
+BuildRequires: glib2-devel
+%endif
+%if 0%{?suse_version} >= 1210
+BuildRequires: glibc-devel-static
+%endif
+%if 0%{?suse_version} >= 1210
+BuildRequires: libattr-devel-static
+%else
+BuildRequires: libattr-devel
+%endif
+%if 0%{?suse_version} > 1220
+BuildRequires: makeinfo
+%endif
+BuildRequires: ncurses-devel
+%if 0%{?suse_version} >= 1220
+BuildRequires: pcre-devel-static
+%endif
+BuildRequires: python
+%if 0%{?suse_version} >= 1120
+BuildRequires: zlib-devel-static
+%else
+BuildRequires: zlib-devel
+%endif
+# we must not install the qemu-linux-user package when under QEMU build
+%if 0%{?qemu_user_space_build:1}
+#!BuildIgnore: post-build-checks
+%endif
+Provides: qemu:%_bindir/qemu-arm
+
+%description
+QEMU is an extremely well-performing CPU emulator that allows you to
+choose between simulating an entire system and running userspace
+binaries for different architectures under your native operating
+system. It currently emulates x86, ARM, PowerPC and SPARC CPUs as well
+as PC and PowerMac systems.
+
+This sub-package contains statically linked binaries for running linux-user
+emulations. This can be used together with the OBS build script to
+run cross-architecture builds.
+
+%prep
+%setup -q -n qemu-2.7.0
+
+%build
+./configure --prefix=%_prefix --sysconfdir=%_sysconfdir \
+ --libexecdir=%_libexecdir \
+ --enable-linux-user \
+ --disable-system \
+ --disable-tools \
+ --disable-guest-agent \
+ --static --disable-linux-aio \
+ --disable-fdt \
+ --without-pixman \
+ --disable-blobs \
+ --disable-strip \
+ --extra-cflags="$QEMU_OPT_FLAGS"
+%if 0%{?suse_version} == 1140
+# -lrt needs to come after -lglib-2.0 to avoid undefined clock_gettime
+sed -i "s/-lglib-2.0/-lglib-2.0 -lrt/" config-host.mak
+%endif
+make %{?_smp_mflags} V=1
+
+%ifarch %ix86
+%define qemu_arch i386
+%endif
+%ifarch x86_64
+%define qemu_arch x86_64
+%endif
+%ifarch %arm
+%define qemu_arch arm
+%endif
+%ifarch aarch64
+%define qemu_arch aarch64
+%endif
+%ifarch ppc
+%define qemu_arch ppc
+%endif
+%ifarch ppc64
+%define qemu_arch ppc64
+%endif
+%ifarch ppc64le
+%define qemu_arch ppc64le
+%endif
+%ifarch s390x
+%define qemu_arch s390x
+%endif
+
+%ifarch %ix86 x86_64 %arm aarch64 ppc ppc64 ppc64le s390x
+%if 0%{?suse_version} >= 1310
+%check
+%{qemu_arch}-linux-user/qemu-%{qemu_arch} %_bindir/ls > /dev/null
+%endif
+%endif
+
+%install
+make install DESTDIR=$RPM_BUILD_ROOT
+rm -fr $RPM_BUILD_ROOT/%_datadir/doc
+rm -f $RPM_BUILD_ROOT/%_mandir/man1/qemu.1
+rm -f $RPM_BUILD_ROOT/%_mandir/man1/qemu-img.1
+rm -f $RPM_BUILD_ROOT/%_mandir/man8/qemu-nbd.8
+rm -rf $RPM_BUILD_ROOT/%_datadir/qemu/keymaps
+rm -f $RPM_BUILD_ROOT/%_datadir/qemu/trace-events-all
+rm -f $RPM_BUILD_ROOT/%_sysconfdir/qemu/target-x86_64.conf
+rm -f $RPM_BUILD_ROOT/%_libexecdir/qemu-bridge-helper
+install -d -m 755 $RPM_BUILD_ROOT/%_sbindir
+install -m 755 scripts/qemu-binfmt-conf.sh $RPM_BUILD_ROOT/%_sbindir
+%ifnarch %ix86 x86_64
+ln -sf ../../../emul/ia32-linux $RPM_BUILD_ROOT/usr/share/qemu/qemu-i386
+%endif
+%ifnarch ia64
+mkdir -p $RPM_BUILD_ROOT/emul/ia32-linux
+%endif
+%fdupes -s $RPM_BUILD_ROOT
+
+%clean
+rm -rf ${RPM_BUILD_ROOT}
+
+%files
+%defattr(-, root, root)
+%_bindir/qemu-aarch64
+%_bindir/qemu-alpha
+%_bindir/qemu-arm
+%_bindir/qemu-armeb
+%_bindir/qemu-cris
+%_bindir/qemu-i386
+%_bindir/qemu-m68k
+%_bindir/qemu-microblaze
+%_bindir/qemu-microblazeel
+%_bindir/qemu-mips
+%_bindir/qemu-mipsel
+%_bindir/qemu-mipsn32
+%_bindir/qemu-mipsn32el
+%_bindir/qemu-mips64
+%_bindir/qemu-mips64el
+%_bindir/qemu-or32
+%_bindir/qemu-ppc64abi32
+%_bindir/qemu-ppc64
+%_bindir/qemu-ppc64le
+%_bindir/qemu-ppc
+%_bindir/qemu-s390x
+%_bindir/qemu-sh4
+%_bindir/qemu-sh4eb
+%_bindir/qemu-sparc32plus
+%_bindir/qemu-sparc64
+%_bindir/qemu-sparc
+%_bindir/qemu-tilegx
+%_bindir/qemu-unicore32
+%_bindir/qemu-x86_64
+%_bindir/qemu-*-binfmt
+%_sbindir/qemu-binfmt-conf.sh
+%ifnarch %ix86 x86_64 ia64
+%dir /emul/ia32-linux
+%endif
+%ifnarch %ix86 x86_64
+%dir /usr/share/qemu
+/usr/share/qemu/qemu-i386
+%endif
+
+%changelog