summaryrefslogtreecommitdiff
path: root/packaging/qemu-accel-aarch64.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/qemu-accel-aarch64.spec')
-rw-r--r--packaging/qemu-accel-aarch64.spec9
1 files changed, 9 insertions, 0 deletions
diff --git a/packaging/qemu-accel-aarch64.spec b/packaging/qemu-accel-aarch64.spec
index 6c2ebbb..1415e94 100644
--- a/packaging/qemu-accel-aarch64.spec
+++ b/packaging/qemu-accel-aarch64.spec
@@ -443,6 +443,15 @@ awk '/post "/ && !x {print " post \"echo '%{our_path}/lib' >> /etc/ld.so.conf\"
find %{buildroot}%{our_path}%{_libdir} -name 'ld-*.so' -delete
sed -e '\|%{our_path}%{_libdir}/ld-[[:digit:]].*\.so|d' -i %{_sourcedir}/all-accel.list
+# We could not use annobin plugin that runs on armv7l/aarch64-tizen-linux-gnu
+# compiler but build on a x86_64/i586 due to different ABI's layout. Disable
+# cc1/cc1plus acceleration.
+%if 0%{?annobin_verification}
+find %{buildroot}%{our_path} -name 'cc1' -delete -or -name 'cc1plus' -delete
+sed -e '\|%{our_path}/.*cc1$|d' -i %{_sourcedir}/all-accel.list
+sed -e '\|%{our_path}/.*cc1plus$|g' -i %{_sourcedir}/all-accel.list
+%endif
+
# allow build of baselibs.conf
sed -e "/targettype %{cross} block!/d" -i %{_sourcedir}/baselibs.conf