diff options
author | Jesse Hellemn <hellemn@fb.com> | 2019-01-08 15:04:13 -0800 |
---|---|---|
committer | Facebook Github Bot <facebook-github-bot@users.noreply.github.com> | 2019-01-08 15:06:55 -0800 |
commit | 4f51ca490ed89329ca7cba5a71d691598381de82 (patch) | |
tree | 6d9b752d5f08d439932718d0d71b0f439b396d17 /setup.py | |
parent | acc83ad54ef85eacd3c7ebfe20ee8225164e5bd1 (diff) | |
download | pytorch-4f51ca490ed89329ca7cba5a71d691598381de82.tar.gz pytorch-4f51ca490ed89329ca7cba5a71d691598381de82.tar.bz2 pytorch-4f51ca490ed89329ca7cba5a71d691598381de82.zip |
Correcting source pybind11 library to install into Python
Summary: Pull Request resolved: https://github.com/pytorch/pytorch/pull/15836
Reviewed By: anderspapitto
Differential Revision: D13601331
Pulled By: pjh5
fbshipit-source-id: 36785c501774c01f47acb49cdac265b2c95a5040
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -595,7 +595,7 @@ class build_ext(build_ext_parent): def build_extensions(self): # The caffe2 extensions are created in - # build/caffe2/python/ + # <pytorch_root>/torch/lib/pythonM.m/site-packages/caffe2/python/ # and need to be copied to build/lib.linux.... , which will be a # platform dependent build folder created by the "build" command of # setuptools. Only the contents of this folder are installed in the @@ -616,7 +616,7 @@ class build_ext(build_ext_parent): filename = self.get_ext_filename(fullname) report("\nCopying extension {}".format(ext.name)) - src = os.path.join('build', filename) + src = os.path.join(cwd, 'torch', rel_site_packages, filename) if not os.path.exists(src): report("{} does not exist".format(src)) del self.extensions[i] |