diff options
author | Sebastian Messmer <messmer@fb.com> | 2019-01-17 15:47:16 -0800 |
---|---|---|
committer | Facebook Github Bot <facebook-github-bot@users.noreply.github.com> | 2019-01-17 15:56:52 -0800 |
commit | 3e85a2bcbfb1c0275ed61122e6a70a50ba2deece (patch) | |
tree | 5412d1025171a3c496505a619e7708c0c78fa577 /setup.py | |
parent | a9438ba62f02af5032171c3773bfc54c348de298 (diff) | |
download | pytorch-3e85a2bcbfb1c0275ed61122e6a70a50ba2deece.tar.gz pytorch-3e85a2bcbfb1c0275ed61122e6a70a50ba2deece.tar.bz2 pytorch-3e85a2bcbfb1c0275ed61122e6a70a50ba2deece.zip |
Move c10 dispatcher back to ATen/core (#16050)
Summary:
Pull Request resolved: https://github.com/pytorch/pytorch/pull/16050
The c10 dispatcher will (soon) depend on IValue and IValue can't be moved to c10 yet because it depends on at::Tensor, which depends on legacy Type dispatch and we don't want the legacy dispatch in c10.
So instead, we move the c10 dispatcher back to ATen/core until we can actually move at::Tensor to c10.
Reviewed By: ezyang
Differential Revision: D13684517
fbshipit-source-id: 1125f4254223907c52f96ff73034f6d4ae9fd0a7
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -860,9 +860,9 @@ if __name__ == '__main__': 'lib/include/c10/*.h', 'lib/include/c10/macros/*.h', 'lib/include/c10/core/*.h', - 'lib/include/c10/core/dispatch/*.h', + 'lib/include/ATen/core/dispatch/*.h', 'lib/include/c10/core/impl/*.h', - 'lib/include/c10/core/opschema/*.h', + 'lib/include/ATen/core/opschema/*.h', 'lib/include/c10/util/*.h', 'lib/include/c10/cuda/*.h', 'lib/include/c10/cuda/impl/*.h', |