summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorgchanan <gregchanan@gmail.com>2018-02-21 17:37:59 -0500
committerGitHub <noreply@github.com>2018-02-21 17:37:59 -0500
commit0878c6d4d77103070740041623df0557419097c9 (patch)
tree28170f92aefc4872ddd5ec8e65634c1e96900737 /setup.py
parent702a7f386432108ec28fcabce2958e4ab11eae5b (diff)
downloadpytorch-0878c6d4d77103070740041623df0557419097c9.tar.gz
pytorch-0878c6d4d77103070740041623df0557419097c9.tar.bz2
pytorch-0878c6d4d77103070740041623df0557419097c9.zip
Various dtype improvements. (#5321)
* Various dtype improvements. 1) Add dtypes to the new data-based constructors: Variable.new_tensor and torch.autograd.variable. 2) In the python signatures, use Type instead of Dtype to match the C++ signatures; the error messages still print as dtype. 3) Handle / add a better error message when a dtype is used when ATen was not compiled with that type (e.g. cuda types). 4) Move cuda_lazy_init to its own file. A later commit will add support to the legacy constructors as well. * Move implementation of lazy_init to cpp. * Fix parsed_arg size.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9d0c542760..2811dc2992 100644
--- a/setup.py
+++ b/setup.py
@@ -682,6 +682,7 @@ if WITH_CUDA:
"torch/csrc/cuda/comm.cpp",
"torch/csrc/cuda/python_comm.cpp",
"torch/csrc/cuda/expand_utils.cpp",
+ "torch/csrc/cuda/lazy_init.cpp",
"torch/csrc/cuda/serialization.cpp",
]
main_sources += split_types("torch/csrc/cuda/Tensor.cpp", ninja_global)