summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPeter Goldsborough <peter@goldsborough.me>2018-02-23 07:15:30 -0800
committerSoumith Chintala <soumith@gmail.com>2018-02-23 10:15:30 -0500
commit008ba18c5bc2a8fb5f061e812c18c531887d946e (patch)
tree5b1bea6274f7f4b85a36de2281f278fc656e1913 /setup.py
parente2519e7dd15de727e2da0d1e9220dd662be39df7 (diff)
downloadpytorch-008ba18c5bc2a8fb5f061e812c18c531887d946e.tar.gz
pytorch-008ba18c5bc2a8fb5f061e812c18c531887d946e.tar.bz2
pytorch-008ba18c5bc2a8fb5f061e812c18c531887d946e.zip
Improve CUDA extension support (#5324)
* Also pass torch includes to nvcc build * Export ATen/cuda headers with install * Refactor flags common to C++ and CUDA * Improve tests for C++/CUDA extensions * Export .cuh files under THC * Refactor and clean cpp_extension.py slightly * Include ATen in cuda extension test * Clarifying comment in cuda_extension.cu * Replace cuda_extension.cu with cuda_extension_kernel.cu in setup.py * Copy compile args in C++ extension and add second kernel * Conditionally add -std=c++11 to cuda_flags * Also export cuDNN headers * Add comment about deepcopy
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a0066083a3..9b3d45d09d 100644
--- a/setup.py
+++ b/setup.py
@@ -864,11 +864,15 @@ if __name__ == '__main__':
'lib/torch_shm_manager',
'lib/*.h',
'lib/include/ATen/*.h',
+ 'lib/include/ATen/cuda/*.cuh',
+ 'lib/include/ATen/cudnn/*.h',
+ 'lib/include/ATen/cuda/detail/*.cuh',
'lib/include/pybind11/*.h',
'lib/include/pybind11/detail/*.h',
'lib/include/TH/*.h',
'lib/include/TH/generic/*.h',
'lib/include/THC/*.h',
+ 'lib/include/THC/*.cuh',
'lib/include/THC/generic/*.h',
'lib/include/torch/csrc/*.h',
'lib/include/torch/csrc/autograd/*.h',