summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOrion Reblitz-Richardson <orionr@gmail.com>2018-08-29 10:02:12 -0700
committerFacebook Github Bot <facebook-github-bot@users.noreply.github.com>2018-08-29 10:09:52 -0700
commitb41988c71ed7d40af7a314b2049a4b0d5909fed2 (patch)
tree3e86056ac1afc6ecccd9a7985f6a2fe492db7559 /CMakeLists.txt
parent7169906249fb57e0a9be00902abcb26457dcc14c (diff)
downloadpytorch-b41988c71ed7d40af7a314b2049a4b0d5909fed2.tar.gz
pytorch-b41988c71ed7d40af7a314b2049a4b0d5909fed2.tar.bz2
pytorch-b41988c71ed7d40af7a314b2049a4b0d5909fed2.zip
Cleanup BUILD_DOCS cmake section (#11000)
Summary: Breaking out of https://github.com/pytorch/pytorch/pull/8338 cc mingzhe09088 Yangqing Pull Request resolved: https://github.com/pytorch/pytorch/pull/11000 Differential Revision: D9557474 Pulled By: orionr fbshipit-source-id: 7d84914b67ff37bdb7738f9b7846dfeb5b975c00
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1009e5a4ec..75b4bf7b45 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -306,7 +306,7 @@ if(BUILD_DOCS)
if(EXISTS ${CMAKE_CURRENT_BINARY_DIR}/docs)
file(REMOVE_RECURSE ${CMAKE_CURRENT_BINARY_DIR}/docs)
- endif (EXISTS ${CMAKE_CURRENT_BINARY_DIR}/docs)
+ endif()
file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/docs)
configure_file(${DOXYGEN_C_IN} ${DOXYGEN_C_OUT} @ONLY)
@@ -323,10 +323,10 @@ if(BUILD_DOCS)
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
COMMENT "Generating Python API documentation with Doxygen"
VERBATIM)
- else (DOXYGEN_FOUND)
+ else()
message(FATAL_ERROR "Doxygen needs to be installed to generate the documentation")
- endif (DOXYGEN_FOUND)
-endif (BUILD_DOCS)
+ endif()
+endif()
# ---[ CMake related files
# Uninistall option.