summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Sanders <dsanders11@ucsbalum.com>2015-10-19 13:03:34 -0700
committerDavid Sanders <dsanders11@ucsbalum.com>2015-10-19 13:03:34 -0700
commit922442fe0251df29b3494a2aa93a0d3f18155481 (patch)
treef5f45fbb7710167485e3d57a6cabda8f792e52f9 /setup.py
parentac4433cf550762f53459d330c41a98178a4f9713 (diff)
downloadpython-numpy-922442fe0251df29b3494a2aa93a0d3f18155481.tar.gz
python-numpy-922442fe0251df29b3494a2aa93a0d3f18155481.tar.bz2
python-numpy-922442fe0251df29b3494a2aa93a0d3f18155481.zip
Fix use of __doc__ in setup.py for -OO mode
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8e5c3d04f..106a5fa13 100755
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,7 @@ basic linear algebra and random number generation.
"""
from __future__ import division, print_function
-DOCLINES = __doc__.split("\n")
+DOCLINES = (__doc__ or '').split("\n")
import os
import sys