summaryrefslogtreecommitdiff
path: root/packaging/python-elementary.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/python-elementary.spec')
-rw-r--r--packaging/python-elementary.spec8
1 files changed, 5 insertions, 3 deletions
diff --git a/packaging/python-elementary.spec b/packaging/python-elementary.spec
index 1b9e573..f2676c5 100644
--- a/packaging/python-elementary.spec
+++ b/packaging/python-elementary.spec
@@ -9,9 +9,9 @@ Source: %{name}-%{version}.tar.bz2
Source1001: python-elementary.manifest
BuildRequires: python-devel
BuildRequires: pkgconfig(elementary)
+BuildRequires: pkgconfig(ecore-x)
BuildRequires: pkgconfig(python-ecore)
BuildRequires: pkgconfig(python-evas)
-BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Elementary python bindings.
@@ -27,6 +27,10 @@ Development files for %{name}.
%setup -q
cp %{SOURCE1001} .
+# prevent FTBFS on wrong timestamps
+file=./elementary/elementary.c_elementary.c
+[ ! -r $file ] || touch $file
+
%build
%configure
make %{?_smp_mflags}
@@ -46,5 +50,3 @@ make %{?_smp_mflags}
%{_datadir}/python-elementary/examples
%{_libdir}/pkgconfig/*.pc
-
-%changelog