summaryrefslogtreecommitdiff
path: root/m4/Makefile.am
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-11-06 07:10:54 -0800
committerAnas Nashif <anas.nashif@intel.com>2012-11-06 07:10:54 -0800
commitede95f2eabeab645352a36af072ee998c400bca1 (patch)
treefcd5dc9c73c1bdc0444deee28a9b329f62a2ed7b /m4/Makefile.am
downloadppl-upstream/0.11.2.tar.gz
ppl-upstream/0.11.2.tar.bz2
ppl-upstream/0.11.2.zip
Imported Upstream version 0.11.2upstream/0.11.2upstream
Diffstat (limited to 'm4/Makefile.am')
-rw-r--r--m4/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/m4/Makefile.am b/m4/Makefile.am
new file mode 100644
index 000000000..313d28ab8
--- /dev/null
+++ b/m4/Makefile.am
@@ -0,0 +1,66 @@
+# Automake source file for the Parma Polyhedra Library.
+# Copyright (C) 2001-2010 Roberto Bagnara <bagnara@cs.unipr.it>
+# Copyright (C) 2010-2011 BUGSENG srl (http://bugseng.com)
+#
+# This file is part of the Parma Polyhedra Library (PPL).
+#
+# The PPL is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; either version 3 of the License, or (at your
+# option) any later version.
+#
+# The PPL is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software Foundation,
+# Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02111-1307, USA.
+#
+# For the most up-to-date information see the Parma Polyhedra Library
+# site: http://www.cs.unipr.it/ppl/ .
+
+# M4 macro files to be used by the client applications with Autoconf.
+m4datadir = $(datadir)/aclocal
+m4data_DATA = \
+ppl.m4 \
+ppl_c.m4
+
+# M4 macro files for internal use.
+m4macros = \
+ac_check_ciao.m4 \
+ac_check_classpath.m4 \
+ac_check_fpu_control.m4 \
+ac_check_gmp.m4 \
+ac_check_sicstus_prolog.m4 \
+ac_check_swi_prolog.m4 \
+ac_check_xsb_prolog.m4 \
+ac_cxx_attribute_weak.m4 \
+ac_cxx_double_binary_format.m4 \
+ac_cxx_double_exact_output.m4 \
+ac_cxx_flexible_arrays.m4 \
+ac_cxx_float_binary_format.m4 \
+ac_cxx_float_exact_output.m4 \
+ac_cxx_ieee_inexact_flag.m4 \
+ac_cxx_limit_memory.m4 \
+ac_cxx_long_double_binary_format.m4 \
+ac_cxx_long_double_exact_output.m4 \
+ac_cxx_plain_char_is_signed.m4 \
+ac_cxx_proper_long_double.m4 \
+ac_cxx_remainder_bug.m4 \
+ac_prog_jar.m4 \
+ac_prog_java.m4 \
+ac_prog_javac.m4 \
+ac_prog_javah.m4 \
+ac_text_md5sum.m4 \
+lib-ld.m4 \
+lib-link.m4 \
+lib-prefix.m4 \
+libtool.m4 \
+ltoptions.m4 \
+ltsugar.m4 \
+ltversion.m4 \
+lt~obsolete.m4
+
+EXTRA_DIST = $(m4macros) $(m4data_DATA)