summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3d1902e..98f8cc1 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -68,11 +68,15 @@ my %prereqs = (
"warnings" => 0,
);
-my %xsbuild = (
+my %xsbuild_concat = (
DEFINE => '-DHAVE_UTF8',
OBJECT => '$(O_FILES)',
- Alien::Base::Wrapper->mm_args,
);
+my %xsbuild = Alien::Base::Wrapper->mm_args; # Might contain a definition of DEFINE, must thus concatenate.
+while (my ($k, $v) = each %xsbuild_concat) {
+ my $base_val = $xsbuild{$k};
+ $xsbuild{$k} = (defined($base_val) ? ($base_val . ' ' . $v) : $v);
+}
my %WriteMakefileArgs = (
"NAME" => "XML::LibXML",