summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThierry Escande <thierry.escande@linux.intel.com>2012-12-14 15:34:00 +0100
committerSamuel Ortiz <sameo@linux.intel.com>2013-01-06 22:47:01 +0100
commit994489ccbdf7fb9543ea9595e0752c3fce9bbc60 (patch)
treed3584c4a4ea2a7010022835fb815a20adb6f2759 /Makefile.am
parent471d4fe3ed7569e5202308b490c640f4c57e59cf (diff)
downloadneard-994489ccbdf7fb9543ea9595e0752c3fce9bbc60.tar.gz
neard-994489ccbdf7fb9543ea9595e0752c3fce9bbc60.tar.bz2
neard-994489ccbdf7fb9543ea9595e0752c3fce9bbc60.zip
neard: nfctool: Add LLCP traffic sniffing feature
nfctool -d nfcX --sniffer This dumps LLCP frames to stdout (Hex+ASCII display) nfctool -d nfcX --sniffer --pcap-file FILENAME This saves LLCP frames in pcap format to file FILENAME. This pcap file can be opened in wireshark (v>=1.8.2) with the wireshark-nfc plugin available at http://code.google.com/p/wireshark-nfc/
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 79110a5..f2ca340 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -86,7 +86,8 @@ tools_snep_send_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
src/bluetooth.c src/ndef.c tools/snep-send.c src/agent.c
tools_snep_send_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
-tools_nfctool_nfctool_SOURCES = tools/nfctool/main.c tools/nfctool/netlink.c
+tools_nfctool_nfctool_SOURCES = tools/nfctool/main.c tools/nfctool/netlink.c \
+ tools/nfctool/sniffer.c
tools_nfctool_nfctool_LDADD = @GLIB_LIBS@ @NETLINK_LIBS@
endif