summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d53bb10..dc98799 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -572,6 +572,11 @@ if(NCNN_TARGET_ARCH STREQUAL "arm" AND CMAKE_SIZEOF_VOID_P EQUAL 8)
# disable this feature for fixing linking atomic builtins issue with old ndk
target_compile_options(ncnn PRIVATE -mno-outline-atomics)
endif()
+
+ find_library(MVEC_LIB "mvec")
+ if (MVEC_LIB)
+ target_link_libraries(ncnn PRIVATE mvec)
+ endif()
endif()
if(NCNN_TARGET_ARCH STREQUAL "mips")