summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorH. Peter Anvin <hpa@zytor.com>2007-04-15 22:45:25 +0000
committerH. Peter Anvin <hpa@zytor.com>2007-04-15 22:45:25 +0000
commit1ed0387476138f83ba173d161a54b779353d11aa (patch)
tree400c94f942c8ee12d59aefa1ed1243883f8ce550 /configure.in
parent3faf938f79c0ded2d72483a149956eba8169b2d2 (diff)
downloadnasm-1ed0387476138f83ba173d161a54b779353d11aa.tar.gz
nasm-1ed0387476138f83ba173d161a54b779353d11aa.tar.bz2
nasm-1ed0387476138f83ba173d161a54b779353d11aa.zip
Cleaner way to add gcc options
We can actually test for the options being accepted, rather than try to test for gcc; this handles differences between gcc versions as well as compilers with a similar command line set.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 74e784c..b9d091a 100644
--- a/configure.in
+++ b/configure.in
@@ -59,12 +59,11 @@ else
fi
AC_PROG_INSTALL
-if test "$GCC" = "yes"; then
- GCCFLAGS="-W -Wall -std=c99 -pedantic"
-else
- GCCFLAGS=
-fi
-AC_SUBST(GCCFLAGS)
+dnl If we have gcc, add appropriate options
+PA_ADD_CFLAGS([-W])
+PA_ADD_CFLAGS([-Wall])
+PA_ADD_CFLAGS([-std=c99])
+PA_ADD_CFLAGS([-pedantic])
dnl Look for "nroff" or "groff"
AC_CHECK_PROGS(NROFF, nroff, echo)