summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorH. Peter Anvin <hpa@zytor.com>2007-10-26 18:49:29 -0700
committerH. Peter Anvin <hpa@zytor.com>2007-10-26 18:49:29 -0700
commitc13d31a907a5d8406b9f07bb782db76e56634c2d (patch)
treef8ed7838812165fd2636ef172fa6e48258cba732 /configure.in
parent31600d6988ce92cf29af3de905556868d9c5d2d3 (diff)
downloadnasm-c13d31a907a5d8406b9f07bb782db76e56634c2d.tar.gz
nasm-c13d31a907a5d8406b9f07bb782db76e56634c2d.tar.bz2
nasm-c13d31a907a5d8406b9f07bb782db76e56634c2d.zip
Better handling of platforms which hide "extended" functionality
Some platforms apparently feel -std=c99, which defines __STRICT_ANSI__, should also hide a bunch of function prototypes. This rather sucks. At least try to deal with it. MinGW and DJGPP both have this problem, in particular.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 93759fd..da26da9 100644
--- a/configure.in
+++ b/configure.in
@@ -124,6 +124,15 @@ AC_CHECK_FUNCS(strsep)
AC_CHECK_FUNCS(getuid)
AC_CHECK_FUNCS(getgid)
+dnl Check for functions that might not be declared in the headers for
+dnl various idiotic reasons (mostly because of library authors
+dnl abusing the meaning of __STRICT_ANSI__)
+AC_CHECK_DECLS(strcasecmp)
+AC_CHECK_DECLS(stricmp)
+AC_CHECK_DECLS(strncasecmp)
+AC_CHECK_DECLS(strnicmp)
+AC_CHECK_DECLS(strsep)
+
if test $ac_cv_prog_make_vpathok = no; then
echo Copying generated srcs into build directory to compensate for VPATH breakage
for file in macros.c insnsa.c insnsd.c insnsn.c insnsi.h version.h version.mac; do