summaryrefslogtreecommitdiff
path: root/src/murphy-db/Makefile.am
diff options
context:
space:
mode:
authorDoohwan Kim <dh8210.kim@samsung.com>2015-02-26 17:39:16 +0900
committerDoohwan Kim <dh8210.kim@samsung.com>2015-02-26 17:39:45 +0900
commitda07ee69267b4557028357eae802d2a7a57c34e7 (patch)
tree02a5d7590fc35cd3ad08aa8894ca5f32947a1da1 /src/murphy-db/Makefile.am
parent34c41c0eecd122a3dd92b30f30267ea4d951343a (diff)
downloadmurphy-tizen_3.0.2015.q1_common.tar.gz
murphy-tizen_3.0.2015.q1_common.tar.bz2
murphy-tizen_3.0.2015.q1_common.zip
Signed-off-by: Doohwan Kim <dh8210.kim@samsung.com> Change-Id: I2ad7e23e121506673a724f512fea429489928451
Diffstat (limited to 'src/murphy-db/Makefile.am')
-rw-r--r--src/murphy-db/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/murphy-db/Makefile.am b/src/murphy-db/Makefile.am
new file mode 100644
index 0000000..38d4a94
--- /dev/null
+++ b/src/murphy-db/Makefile.am
@@ -0,0 +1,21 @@
+if HAVE_CHECK
+TESTDIR = tests
+else
+TESTDIR =
+endif
+
+SUBDIRS = mdb mqi mql include $(TESTDIR)
+
+pkgconfigdir = $(libdir)/pkgconfig
+nodist_pkgconfig_DATA = murphy-db.pc
+
+murphy-db.pc: murphy-db.pc.in
+ sed -e 's![@]prefix[@]!$(prefix)!g' \
+ -e 's![@]exec_prefix[@]!$(exec_prefix)!g' \
+ -e 's![@]includedir[@]!$(includedir)!g' \
+ -e 's![@]libdir[@]!$(libdir)!g' \
+ -e 's![@]PACKAGE_VERSION[@]!$(PACKAGE_VERSION)!g' \
+ $< > $@
+
+clean-local:
+ rm -f *~ murphy-db.pc