summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorEd Bartosh <eduard.bartosh@intel.com>2012-10-04 17:42:09 +0300
committerEd Bartosh <eduard.bartosh@intel.com>2012-11-24 20:24:33 +0200
commitaaee947d5ad2c0efdbcb270346c5176647686c88 (patch)
tree067047a73f65e05d8038269bb51a4e9e2e9a43eb /debian/rules
parent0750ca146e0e69c81138aef3b0bbe19caaa09928 (diff)
downloadmic-aaee947d5ad2c0efdbcb270346c5176647686c88.tar.gz
mic-aaee947d5ad2c0efdbcb270346c5176647686c88.tar.bz2
mic-aaee947d5ad2c0efdbcb270346c5176647686c88.zip
Integrated mic with "OTC Tools Tester" Jenkins machinery
OTC Tester expects that cd packaging/ && make all produces all needed packaging files. This change makes it happen. Beside of that tests/mic-test.py was fixed, because Tools Tester job runs nose if tests/ directory presents in the source tree and expects some tests results. Results were not generated, so fake test has been added there. Change-Id: I08f7b5c6012fbefef640177bce13c301fcf826c0 Signed-off-by: Ed Bartosh <eduard.bartosh@intel.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules55
1 files changed, 55 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..5346591
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,55 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+ python setup.py build
+ make man
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Installing package
+ mkdir -p $(CURDIR)/debian/mic $(CURDIR)/debian/mic/usr/bin $(CURDIR)/debian/mic/usr/share/man/man1
+ install -m644 mic.1 $(CURDIR)/debian/mic/usr/share/man/man1
+ #make DESTDIR=$(CURDIR)/debian/mic installman
+ #make DESTDIR=$(CURDIR)/debian/micng installconf
+ #make DESTDIR=$(CURDIR)/debian/micng installsymlinks
+ python setup.py install --root=$(CURDIR)/debian/mic
+
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_install
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_pysupport
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary-arch: build install
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install