summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 2b6fb31a34c..37c323200a8 100644
--- a/meson.build
+++ b/meson.build
@@ -1624,9 +1624,10 @@ if with_gallium_opencl
endif
if with_clc
llvm_modules += ['coverage', 'target', 'linker', 'irreader', 'option', 'libdriver', 'lto']
- # all-targets is needed to support static linking LLVM build with multiple targets
- # windowsdriver is needded with LLVM>=15, but we don't know what LLVM verrsion we are using yet
- llvm_optional_modules += ['all-targets', 'windowsdriver']
+ # all-targets is needed to support static linking LLVM build with multiple targets.
+ # windowsdriver is needded with LLVM>=15 and frontendhlsl is needed with LLVM>=16,
+ # but we don't know what LLVM version we are using yet
+ llvm_optional_modules += ['all-targets', 'windowsdriver', 'frontendhlsl']
endif
draw_with_llvm = get_option('draw-use-llvm')
if draw_with_llvm