summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorJesse Natalie <jenatali@microsoft.com>2020-11-06 17:09:30 +0100
committerMarge Bot <eric+marge@anholt.net>2020-11-18 04:05:37 +0000
commitff05da7f8dc4aa531704d48f718514e3b1fff45d (patch)
tree42b328eaf716d1ac49d3af45beecfc6f27c62e9a /src/meson.build
parent1885e356e6a4d425471c0bfa0aee5fcf98d19186 (diff)
downloadmesa-ff05da7f8dc4aa531704d48f718514e3b1fff45d.tar.gz
mesa-ff05da7f8dc4aa531704d48f718514e3b1fff45d.tar.bz2
mesa-ff05da7f8dc4aa531704d48f718514e3b1fff45d.zip
microsoft: Add CLC frontend and kernel/compute support to DXIL converter
This adds a standalone library which can convert through the pipeline of OpenCL C -> SPIR -> SPIR-V -> NIR -> DXIL. It can add in the libclc implementations of various library functions in the NIR phase, and also massages the NIR to shift it more towards graphics-style compute. This is leveraged by the out-of-tree OpenCLOn12 runtime (https://github.com/microsoft/OpenCLOn12). This is the combination of a lot of commits from our development branch, containing code by several authors. Co-authored-by: Boris Brezillon <boris.brezillon@collabora.com> Co-authored-by: Daniel Stone <daniels@collabora.com> Co-authored-by: Erik Faye-Lund <erik.faye-lund@collabora.com> Acked-by: Jason Ekstrand <jason@jlekstrand.net> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/7565>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index b5f4933abca..7deb202207a 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -91,7 +91,7 @@ endif
if with_any_intel
subdir('intel')
endif
-if with_gallium_d3d12
+if with_microsoft_clc or with_gallium_d3d12
subdir('microsoft')
endif
subdir('mesa')