summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2019-09-25 23:25:27 +0000
committerDylan Baker <dylan@pnwbakers.com>2019-09-25 23:25:27 +0000
commitfafd20f67dec9f5891838435ecde1dedb77ab742 (patch)
tree48d445d77515eff1b43fb3a89025d84d4e91ea51 /src/meson.build
parent7e53bebcb5867039265b3c8201191b714f3cc347 (diff)
downloadmesa-fafd20f67dec9f5891838435ecde1dedb77ab742.tar.gz
mesa-fafd20f67dec9f5891838435ecde1dedb77ab742.tar.bz2
mesa-fafd20f67dec9f5891838435ecde1dedb77ab742.zip
meson: fix logic for generating .pc files with old glvnd
We want to generate PC files for non-glvnd builds and for builds with old glvnd, but the current logic doesn't do that, it builds them unconditionally, and for GLES it builds the shared libraries, which is also not what we want. This does not generate .pc files for gles1 or gles2. Which it we weren't doing before either, making this not a regression but a return to status-quo.o Closes: https://gitlab.freedesktop.org/mesa/mesa/issues/1838 Fixes: 93df862b6affb6b8507e40601212a58012bfa873 ("meson: re-add incorrect pkg-config files with GLVND for backward compatibility") Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index ddbcd7f3ae4..d01f84c0d46 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -111,12 +111,12 @@ endif
# This must be after at least mesa, glx, and gallium, since libgl will be
# defined in one of those subdirs depending on the glx provider.
-if with_glx != 'disabled'
+if with_glx != 'disabled' and (not with_glvnd or glvnd_missing_pc_files)
# If using glvnd the pkg-config header should not point to GL_mesa, it should
# point to GL. glvnd is only available on unix like platforms so adding -l
# should be safe here
# TODO: in the glvnd case glvnd itself should really be providing this.
- if with_glvnd and glvnd_missing_pc_files
+ if glvnd_missing_pc_files
_gl = '-L${libdir} -lGL'
else
_gl = libgl