summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-04-18 09:29:35 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-04-24 14:08:15 -0700
commitc73abb4f824f70a0dc776389009336121c1d3405 (patch)
treef450d6b3ce95d361b8b0003ab8a2baa264bb504e /src/meson.build
parentaaab6242456a4a5e737da0add179704b0b6f3676 (diff)
downloadmesa-c73abb4f824f70a0dc776389009336121c1d3405.tar.gz
mesa-c73abb4f824f70a0dc776389009336121c1d3405.tar.bz2
mesa-c73abb4f824f70a0dc776389009336121c1d3405.zip
meson: only build mesa_st tests when build-tests is true
Since we have an option to turn test building on and off, we should honor that. Fixes: 34cb4d0ebc14663113705beae63dd52b9d1b2d87 ("meson: build tests for gallium mesa state tracker") Signed-off-by: Dylan Baker <dylan.c.baker@intel.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 5d8d554d711..c2566b7a687 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -82,7 +82,9 @@ if with_gallium
subdir('gallium')
# This has to be here since it requires libgallium, and subdir cannot
# contain ..
- subdir('mesa/state_tracker/tests')
+ if with_tests
+ subdir('mesa/state_tracker/tests')
+ endif
endif
# This must be after at least mesa, glx, and gallium, since libgl will be