summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJuan A. Suarez Romero <jasuarez@igalia.com>2018-06-18 15:45:51 +0200
committerJuan A. Suarez Romero <jasuarez@igalia.com>2018-06-21 12:16:46 +0200
commitd24839be70d66cb74f4eb3c5f76b7ed634bdc7d3 (patch)
tree77d618f894daab9c23cddbc1fab9b789079b1059 /meson.build
parentf966929805f722ae38d4821fab61765c0ee4a60c (diff)
downloadmesa-d24839be70d66cb74f4eb3c5f76b7ed634bdc7d3.tar.gz
mesa-d24839be70d66cb74f4eb3c5f76b7ed634bdc7d3.tar.bz2
mesa-d24839be70d66cb74f4eb3c5f76b7ed634bdc7d3.zip
swr: bump minimum supported LLVM version to 5.0
RADV now requires LLVM 5.0 or greater, and thus we can't build dist tarball because swr requires LLVM 4.0. Let's bump required LLVM to 5.0 in swr too. Fixes: f9eb1ef870 ("amd: remove support for LLVM 4.0") Cc: Tim Rowley <timothy.o.rowley@intel.com> Cc: Emil Velikov <emil.velikov@collabora.com> Cc: Dylan Baker <dylan@pnwbakers.com> Cc: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Acked-by: Bruce Cherniak <bruce.cherniak@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 76aa10f81a5..a2d59776c05 100644
--- a/meson.build
+++ b/meson.build
@@ -1144,10 +1144,8 @@ if with_gallium_opencl
llvm_optional_modules += ['coroutines', 'opencl']
endif
-if with_amd_vk or with_gallium_radeonsi
+if with_amd_vk or with_gallium_radeonsi or with_gallium_swr
_llvm_version = '>= 5.0.0'
-elif with_gallium_swr
- _llvm_version = '>= 4.0.0'
elif with_gallium_opencl or with_gallium_r600
_llvm_version = '>= 3.9.0'
else