summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2018-02-23 19:32:02 +0000
committerEric Engestrom <eric.engestrom@intel.com>2018-05-29 16:31:46 +0100
commit728d1da159e072e7ef9956ba5326cc02f4d2589b (patch)
tree9841f237b582e6128bdc272a8871b1dfff4c120f /meson.build
parent9e539012dfaa848fc4cfde83c3f3a83fee274ca4 (diff)
downloadmesa-728d1da159e072e7ef9956ba5326cc02f4d2589b.tar.gz
mesa-728d1da159e072e7ef9956ba5326cc02f4d2589b.tar.bz2
mesa-728d1da159e072e7ef9956ba5326cc02f4d2589b.zip
meson: remove unreachable with_glx == 'auto' check
Cannot happen since, props to the autodetection further up. Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 1 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index d0cb8961638..d4f460e0b6e 100644
--- a/meson.build
+++ b/meson.build
@@ -344,11 +344,7 @@ endif
pre_args += '-DGLX_USE_TLS'
if with_glx != 'disabled'
if not (with_platform_x11 and with_any_opengl)
- if with_glx == 'auto'
- with_glx = 'disabled'
- else
- error('Cannot build GLX support without X11 platform support and at least one OpenGL API')
- endif
+ error('Cannot build GLX support without X11 platform support and at least one OpenGL API')
elif with_glx == 'gallium-xlib'
if not with_gallium
error('Gallium-xlib based GLX requires at least one gallium driver')