summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorpal1000 <liviuprodea@yahoo.com>2022-08-17 22:29:21 +0300
committerMarge Bot <emma+marge@anholt.net>2022-10-10 12:20:30 +0000
commited2743eae59ac71622395299e522c091ddcee722 (patch)
tree1a57b00962f3454b1e3c3bf18a6e23f22aff20db /meson.build
parent55f6a2bb51a1fadcd68f9f09ccf4435a4e4ca269 (diff)
downloadmesa-ed2743eae59ac71622395299e522c091ddcee722.tar.gz
mesa-ed2743eae59ac71622395299e522c091ddcee722.tar.bz2
mesa-ed2743eae59ac71622395299e522c091ddcee722.zip
clc/clover: Link clang statically when shared-llvm is disabled
Makes things easier to handle when aiming for a static build Cc: mesa-stable Reviewed-by: Karol Herbst <kherbst@redhat.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/18117>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7247c32b9ac..ff26001d3a0 100644
--- a/meson.build
+++ b/meson.build
@@ -1884,7 +1884,7 @@ if with_clc
dep_clang = cpp.find_library('clang-cpp', dirs : llvm_libdir, required : false)
- if not dep_clang.found()
+ if not dep_clang.found() or not _shared_llvm
clang_modules = [
'clangBasic', 'clangAST', 'clangCodeGen', 'clangLex',
'clangDriver', 'clangFrontend', 'clangFrontendTool',