summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJames Park <jpark37@lagfreegames.com>2022-09-08 09:15:00 -0700
committerMarge Bot <emma+marge@anholt.net>2022-09-19 12:51:12 +0000
commitb7d4897df9c51dbef573c46ed76f762b4bc51151 (patch)
tree92ece555750f49b57d8b3c2b2ad6fd380fb93ed6 /meson.build
parent74658b01d2281c34988d589a2ac1861cbbba6b96 (diff)
downloadmesa-b7d4897df9c51dbef573c46ed76f762b4bc51151.tar.gz
mesa-b7d4897df9c51dbef573c46ed76f762b4bc51151.tar.bz2
mesa-b7d4897df9c51dbef573c46ed76f762b4bc51151.zip
meson,amd: Remove Windows libelf wrap
Functionality isn't worth the maintenance cost. Reviewed-by: Samuel Pitoiset <samuel.pitoiset@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/18478>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 6250de545fd..eb419e410f5 100644
--- a/meson.build
+++ b/meson.build
@@ -1908,12 +1908,8 @@ with_opencl_native = _opencl != 'disabled' and get_option('opencl-native')
if (with_amd_vk or with_gallium_radeonsi or
(with_gallium_opencl and with_opencl_native) or
(with_gallium_r600 and with_llvm))
- if with_platform_windows
- dep_elf = dependency('libelf', required : false, fallback : ['libelf', 'libelf_dep'])
- else
- dep_elf = dependency('libelf', required : false)
- endif
- if not dep_elf.found()
+ dep_elf = dependency('libelf', required : false)
+ if not with_platform_windows and not dep_elf.found()
dep_elf = cc.find_library('elf')
endif
else