summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRoman Stratiienko <r.stratiienko@gmail.com>2022-11-28 12:21:06 +0200
committerEric Engestrom <eric@engestrom.ch>2022-11-30 21:12:43 +0000
commita569c68e87ea444fc8a6aa55770cdc7bbf3dceea (patch)
tree28f44cd7118e0ea305f37aa10c4a3ca7725d2300 /meson.build
parentd4f0c6a30c66c3b70343df32dfbb711ed00268b2 (diff)
downloadmesa-a569c68e87ea444fc8a6aa55770cdc7bbf3dceea.tar.gz
mesa-a569c68e87ea444fc8a6aa55770cdc7bbf3dceea.tar.bz2
mesa-a569c68e87ea444fc8a6aa55770cdc7bbf3dceea.zip
meson: Enable system_has_kms_drm for android
This allows to build libgbm when system = 'android' is set in the cross_file. Cc: "22.3" "22.2" mesa-stable Signed-off-by: Roman Stratiienko <r.stratiienko@gmail.com> Acked-by: Mauro Rossi <issor.oruam@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20033> (cherry picked from commit 09ac29cca9bf7978911f81bcfce12ce71c260a97)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c5c138a2a63..5daafad8dce 100644
--- a/meson.build
+++ b/meson.build
@@ -173,7 +173,7 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2
# Only build shared_glapi if at least one OpenGL API is enabled
with_shared_glapi = with_shared_glapi and with_any_opengl
-system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos'].contains(host_machine.system())
+system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android'].contains(host_machine.system())
dri_drivers = get_option('dri-drivers')
if dri_drivers.length() != 0