summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorpal1000 <liviuprodea@yahoo.com>2022-10-10 00:56:03 +0300
committerEric Engestrom <eric@engestrom.ch>2022-12-29 19:25:30 +0000
commit3cfe9bb623f810ab401233338442b180b3cd61bb (patch)
treea4fbe1b22b61b829e53b14a8d933d89d021414c6 /meson.build
parentd03c94fa820ba4d133ba776edd95eb782c5b2b59 (diff)
downloadmesa-3cfe9bb623f810ab401233338442b180b3cd61bb.tar.gz
mesa-3cfe9bb623f810ab401233338442b180b3cd61bb.tar.bz2
mesa-3cfe9bb623f810ab401233338442b180b3cd61bb.zip
OpenCL/draw module: Support linking with LLVM and clang 15 static libraries
Cc: mesa-stable Closes: #7243 Closes: #7487 Reviewed-by: Karol Herbst <kherbst@redhat.com> Reviewed-by: Yonggang Luo <luoyonggang@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19009> (cherry picked from commit f69b43ae3ef9a34ea360d96dfc698f83fad7a823)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 11 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e32338b3f9a..172c64a7c70 100644
--- a/meson.build
+++ b/meson.build
@@ -1739,15 +1739,21 @@ if with_gallium_opencl
'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
'lto', 'option', 'objcarcopts', 'profiledata'
]
- llvm_optional_modules += ['all-targets', 'frontendopenmp']
+ # all-targets is needed to support static linking LLVM build with multiple targets
+ # windowsdriver is needded with LLVM>=15, but we don't know what LLVM verrsion we are using yet
+ llvm_optional_modules += ['all-targets', 'frontendopenmp', 'windowsdriver']
endif
if with_clc
llvm_modules += ['coverage', 'target', 'linker', 'irreader', 'option', 'libdriver', 'lto']
- llvm_optional_modules += ['all-targets']
+ # all-targets is needed to support static linking LLVM build with multiple targets
+ # windowsdriver is needded with LLVM>=15, but we don't know what LLVM verrsion we are using yet
+ llvm_optional_modules += ['all-targets', 'windowsdriver']
endif
draw_with_llvm = get_option('draw-use-llvm')
if draw_with_llvm
llvm_modules += 'native'
+ # lto is needded with LLVM>=15, but we don't know what LLVM verrsion we are using yet
+ llvm_optional_modules += ['lto']
endif
if with_intel_clc
@@ -1905,6 +1911,9 @@ if with_clc
'clangHandleCXX', 'clangHandleLLVM', 'clangSerialization',
'clangSema', 'clangParse', 'clangEdit', 'clangAnalysis'
]
+ if dep_llvm.version().version_compare('>= 15.0')
+ clang_modules += 'clangSupport'
+ endif
dep_clang = []
foreach m : clang_modules