summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <lionel.g.landwerlin@intel.com>2022-09-22 13:08:59 +0300
committerMarge Bot <emma+marge@anholt.net>2022-09-28 05:38:36 +0000
commit262719e963ba838da9f5221152dfeaae65f960ec (patch)
tree48925614fc8910e2424aec81fd3e4cd3e19c7872 /meson.build
parent0926ac42cbdf7191010d1461f1e38e75b6983ed8 (diff)
downloadmesa-262719e963ba838da9f5221152dfeaae65f960ec.tar.gz
mesa-262719e963ba838da9f5221152dfeaae65f960ec.tar.bz2
mesa-262719e963ba838da9f5221152dfeaae65f960ec.zip
meson: bump required llvm-spirv version with intel-clc
Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/16970>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 14 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 23d84adc0b0..3afdbcd0956 100644
--- a/meson.build
+++ b/meson.build
@@ -1771,7 +1771,9 @@ if draw_with_llvm
llvm_modules += 'native'
endif
-if with_amd_vk or with_gallium_radeonsi or with_gallium_opencl
+if with_intel_clc
+ _llvm_version = '>= 13.0.0'
+elif with_amd_vk or with_gallium_radeonsi or with_gallium_opencl
_llvm_version = '>= 11.0.0'
elif with_clc
_llvm_version = '>= 10.0.0'
@@ -1888,12 +1890,18 @@ if with_opencl_spirv
# Require an SPIRV-LLVM-Translator version compatible with the chosen LLVM
# one.
+
+ # This first version check is still needed as maybe LLVM 8.0 was picked but
+ # we do not want to accept SPIRV-LLVM-Translator 8.0.0.1 as that version
+ # does not have the required API and those are only available starting from
+ # 8.0.1.3.
+ _llvmspirvlib_min_version = '>= 8.0.1.3'
+ if with_intel_clc
+ _llvmspirvlib_min_version = '>= 13.0.0.0'
+ endif
+
_llvmspirvlib_version = [
- # This first version check is still needed as maybe LLVM 8.0 was picked but
- # we do not want to accept SPIRV-LLVM-Translator 8.0.0.1 as that version does
- # not have the required API and those are only available starting from
- # 8.0.1.3.
- '>= 8.0.1.3',
+ _llvmspirvlib_min_version,
'>= @0@.@1@'.format(chosen_llvm_version_major, chosen_llvm_version_minor),
'< @0@.@1@'.format(chosen_llvm_version_major, chosen_llvm_version_minor + 1) ]