summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKarol Herbst <kherbst@redhat.com>2020-11-08 20:28:21 +0100
committerMarge Bot <emma+marge@anholt.net>2022-09-12 05:58:12 +0000
commit20c90fed5a0ab0202ee1ef474c71cb816164a448 (patch)
tree1deb5b0120195d933ca493330382c8adcfe0934f /meson.build
parentd431a01d9a87362421df2aa983d5ef92e5bfc4f9 (diff)
downloadmesa-20c90fed5a0ab0202ee1ef474c71cb816164a448.tar.gz
mesa-20c90fed5a0ab0202ee1ef474c71cb816164a448.tar.bz2
mesa-20c90fed5a0ab0202ee1ef474c71cb816164a448.zip
rusticl: added
Initial code drop for Rusticl :) Signed-off-by: Karol Herbst <kherbst@redhat.com> Acked-by: Alyssa Rosenzweig <alyssa.rosenzweig@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/15439>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 16 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4c6c4ffe4ce..2acc4499a48 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,7 @@ project(
).stdout(),
license : 'MIT',
meson_version : '>= 0.53',
- default_options : ['buildtype=debugoptimized', 'b_ndebug=if-release', 'c_std=c11', 'cpp_std=c++17']
+ default_options : ['buildtype=debugoptimized', 'b_ndebug=if-release', 'c_std=c11', 'cpp_std=c++17', 'rust_std=2021']
)
# In recent versions, meson can inject some extra arguments to get richer
@@ -953,6 +953,21 @@ else
with_opencl_icd = false
endif
+with_gallium_rusticl = get_option('gallium-rusticl')
+if with_gallium_rusticl
+ if not with_gallium
+ error('rusticl requires at least one gallium driver.')
+ endif
+
+ if meson.version().version_compare('< 0.61.4')
+ error('rusticl requires meson 0.61.4 or newer')
+ endif
+
+ add_languages('rust', required: true)
+
+ with_clc = true
+endif
+
dep_clc = null_dep
if with_libclc
dep_clc = dependency('libclc')