summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRoman Stratiienko <r.stratiienko@gmail.com>2023-09-21 00:06:15 +0300
committerMarge Bot <emma+marge@anholt.net>2023-09-21 10:50:34 +0000
commitd923d6234dde879eb9b98f51a77d3f3c1ddd2488 (patch)
tree5dc132d00410d38d1c1aab8f6ae9b99d3549066d /meson.build
parent3b6f14c4d36b943b7d462b0f8246834b3cb650ad (diff)
downloadmesa-d923d6234dde879eb9b98f51a77d3f3c1ddd2488.tar.gz
mesa-d923d6234dde879eb9b98f51a77d3f3c1ddd2488.tar.bz2
mesa-d923d6234dde879eb9b98f51a77d3f3c1ddd2488.zip
Revert "util: Add NONNULL macro"
We agreed in [1] not to use it since it has little value, but making a code less readable. [1]: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/25256 This reverts commit 21dcde096f351f83a2df7aa9f42a7276b5454c81. Signed-off-by: Roman Stratiienko <r.stratiienko@gmail.com> Reviewed-by: Yiwei Zhang <zzyiwei@chromium.org> Reviewed-by: Eric Engestrom <eric@igalia.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/25256>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c877eb827ba..b9cba649414 100644
--- a/meson.build
+++ b/meson.build
@@ -926,7 +926,6 @@ endforeach
_attributes = [
'const', 'flatten', 'malloc', 'pure', 'unused', 'warn_unused_result',
'weak', 'format', 'packed', 'returns_nonnull', 'alias', 'noreturn',
- 'nonnull',
]
foreach a : cc.get_supported_function_attributes(_attributes)
pre_args += '-DHAVE_FUNC_ATTRIBUTE_@0@'.format(a.to_upper())