summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarek Olšák <marek.olsak@amd.com>2023-09-04 13:27:09 -0400
committerMarge Bot <emma+marge@anholt.net>2023-09-09 00:56:41 +0000
commitd11900d5e76922790de90ebfb89f918673759a88 (patch)
tree512a3e17bb0018febdf7ded80f9580f1c32b1abb /meson.build
parent6a89507be8a94fe258513812b8934d7fe3af462c (diff)
downloadmesa-d11900d5e76922790de90ebfb89f918673759a88.tar.gz
mesa-d11900d5e76922790de90ebfb89f918673759a88.tar.bz2
mesa-d11900d5e76922790de90ebfb89f918673759a88.zip
meson: use llvm-config instead of cmake to fix linking errors with meson 1.2.1
The cmake path picks a random LLVM in /usr, which happens to be 32-bit LLVM, which fails to link with 64-bit Mesa. This is a meson, cmake, or LLVM bug. Acked-by: Dylan Baker <dylan@pnwbakers.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/25042>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8aa133dbb2e..e4570c59bab 100644
--- a/meson.build
+++ b/meson.build
@@ -1700,6 +1700,7 @@ with_llvm = false
if _llvm.allowed()
dep_llvm = dependency(
'llvm',
+ method : host_machine.system() == 'windows' ? 'auto' : 'config-tool',
version : _llvm_version,
modules : llvm_modules,
optional_modules : llvm_optional_modules,