summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJames Knight <james.d.knight@live.com>2023-04-13 16:38:51 -0400
committerMarge Bot <emma+marge@anholt.net>2023-04-14 16:13:48 +0000
commitcd861b7f38e448822ce765aee61304d1e0a3a8b5 (patch)
treef413dfe808fc87a743abfad4ccf03c3e226b50c5 /meson.build
parentcf90be90aded3ce82d3acda5f63cd59614d662bb (diff)
downloadmesa-cd861b7f38e448822ce765aee61304d1e0a3a8b5.tar.gz
mesa-cd861b7f38e448822ce765aee61304d1e0a3a8b5.tar.bz2
mesa-cd861b7f38e448822ce765aee61304d1e0a3a8b5.zip
meson: ensure i915 Gallium driver includes Intel sources
Ensure builds flag the use of Intel sources when the i915 Gallium driver is configured (`-Dgallium-drivers=i915`). Otherwise, a build may fail if other Intel-based configuration options are not enabled: ./src/gallium/winsys/i915/drm/meson.build:21:0: ERROR: Unknown variable "libintel_common". Signed-off-by: James Knight <james.d.knight@live.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/22490>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 23d2d965b37..a3e3c5478a8 100644
--- a/meson.build
+++ b/meson.build
@@ -245,7 +245,14 @@ with_microsoft_vk = _vulkan_drivers.contains('microsoft-experimental')
with_any_vk = _vulkan_drivers.length() != 0
with_any_broadcom = with_gallium_vc4 or with_gallium_v3d or with_broadcom_vk
-with_any_intel = with_intel_vk or with_intel_hasvk or with_gallium_iris or with_gallium_crocus or with_intel_tools
+with_any_intel = [
+ with_gallium_crocus,
+ with_gallium_i915,
+ with_gallium_iris,
+ with_intel_hasvk,
+ with_intel_tools,
+ with_intel_vk,
+].contains(true)
if with_swrast_vk and not with_gallium_softpipe
error('swrast vulkan requires gallium swrast')