summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@igalia.com>2023-04-13 21:39:37 +0100
committerMarge Bot <emma+marge@anholt.net>2023-05-26 11:30:26 +0000
commitc81b78041ea578c97de79a0e88ed1a4431fcfb59 (patch)
tree888eccf8383ab7a3baf9c35599286194ab5e1f2e /meson.build
parent5feb6133d7753f2784d20f357903348272484891 (diff)
downloadmesa-c81b78041ea578c97de79a0e88ed1a4431fcfb59.tar.gz
mesa-c81b78041ea578c97de79a0e88ed1a4431fcfb59.tar.bz2
mesa-c81b78041ea578c97de79a0e88ed1a4431fcfb59.zip
meson: simplify another "any of" check
Signed-off-by: Eric Engestrom <eric@igalia.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/22491>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 73f27c3c110..9dffae1f7f9 100644
--- a/meson.build
+++ b/meson.build
@@ -244,7 +244,12 @@ with_imagination_srv = get_option('imagination-srv')
with_microsoft_vk = _vulkan_drivers.contains('microsoft-experimental')
with_any_vk = _vulkan_drivers.length() != 0
-with_any_broadcom = with_gallium_vc4 or with_gallium_v3d or with_broadcom_vk
+with_any_broadcom = [
+ with_gallium_vc4,
+ with_gallium_v3d,
+ with_broadcom_vk,
+].contains(true)
+
with_any_intel = [
with_gallium_crocus,
with_gallium_i915,